Log in or register to post comments

Disabling Stereo rendering

October 14, 2019 - 3:09am #1

Hi,

I'm trying to simulate AR in my Oculus Go by mirroring the Unity play mode to my device using ALVR. Each eye gets the same image from my webcam, but Vuforia renderes two different images for my augmentations. That makes the augmentations look 3D, which is not wanted, because they look like they are floating. How can I disable this stereo effect?

 

Many thanks in advance

 

AttachmentSize
Image icon Offset created by Vuforia370.28 KB

Disabling Stereo rendering

October 15, 2019 - 6:27am #5

You're a god. If I scale the ARCamera down after it initialized it works!

Disabling Stereo rendering

October 15, 2019 - 5:56am #4

I actually seem to have found something that works for me. When the scale of the AR camera is set very small, the stereo effect of the object is diminished or even reduced. In my project I have set the x,y and z scales to 0.01 and am happy with the results. Hopefully this helps!

Disabling Stereo rendering

October 15, 2019 - 5:12am #3

I just learned, that changing the graphics API in Unity (build settings > player settings > other settings > graphics API) to OpenGLES3 removes the stereo rendering from Vuforia. The problem is, that now ALVR (or Riftcat) doesn't stream the Unity Editor to my Oculus Go anymore...

Disabling Stereo rendering

October 15, 2019 - 3:16am #2

I would be very interested in an answer to this issue as well.

Log in or register to post comments