Log in or register to post comments

Gear VR with V0.6.0.1

June 29, 2015 - 12:53pm #1

Has anyone tried Oculus V0.6.0.1 on the Gear VR with Vuforia Eyewear beta?  Any hangups or integration issues?

 

Thanks

Gear VR with V0.6.0.1

June 30, 2015 - 3:50am #8

Ok, so, now this is a different issue;

according to the developer guide here:

https://developer.vuforia.com/library/articles/Solution/Developing-for-the-Gear-VR

The (currently) supported Oculus SDK are 0.4 and 0.5.  Try and use 0.5 and follow the integration guide closely.

 

Gear VR with V0.6.0.1

June 30, 2015 - 1:58am #7

Thanks for that. I found the setting and set the API's to OpenGLES2, removing the OpenGLES3 option.

However when I try to build, I get the following errors.

ERROR-01

CommandInvokationFailure: Unable to convert classes into dex format. See the Console for details.
C:\Program Files\Java\jdk1.8.0_20\bin\java.exe -Xmx2048M -Dcom.android.sdkmanager.toolsdir="D:/Android/android-sdk\tools" -Dfile.encoding=UTF8 -jar "d:/Program Files/Unity/Editor/Data/BuildTargetTools/AndroidPlayer\sdktools.jar" -
 
stderr[
 
UNEXPECTED TOP-LEVEL EXCEPTION:
java.lang.IllegalArgumentException: already added: Lcom/facebook/androidcompat/AndroidCompat;
at SDKMain.main(SDKMain.java:129)
 
(many lines removed for brevity)
 
UNEXPECTED TOP-LEVEL EXCEPTION:
java.lang.IllegalArgumentException: already added: Landroid/app/IVRManager;
 
(many lines removed for brevity)
 
ERROR-02
 
Error building Player: CommandInvokationFailure: Unable to convert classes into dex format. See the Console for details.
C:\Program Files\Java\jdk1.8.0_20\bin\java.exe -Xmx2048M -Dcom.android.sdkmanager.toolsdir="D:/Android/android-sdk\tools" -Dfile.encoding=UTF8 -jar "d:/Program Files/Unity/Editor/Data/BuildTargetTools/AndroidPlayer\sdktools.jar" -
 
stderr[
 
UNEXPECTED TOP-LEVEL EXCEPTION:
java.lang.IllegalArgumentException: already added: Lcom/facebook/androidcompat/AndroidCompat;
 
(many lines removed for brevity)
 
UNEXPECTED TOP-LEVEL EXCEPTION:
java.lang.IllegalArgumentException: already added: Landroid/app/IVRManager;
 
(many lines removed for brevity)
 
ERROR-03
 
Multiple plugins with the same name 'qcarwrapper' (found at 'Assets/Plugins/QCARWrapper.dll' and 'Assets/Plugins/QCARWrapper.dll'). That means one or more plugins are set to be compatible with Editor. Only one plugin at the time can be used by Editor.
 
 
Did I do something wrong? I am flying by the seat of my pants here.

Gear VR with V0.6.0.1

June 30, 2015 - 1:27am #6

Sorry, I meant Android Player Settings (not iOS);

the same applies to Android, as you'll find Graphics API in Android Player Settings, see attached screenshot.

 

Gear VR with V0.6.0.1

June 30, 2015 - 12:31am #5

As I'm building this for the Gear VR, I'm building to Android.

Gear VR with V0.6.0.1

June 30, 2015 - 12:25am #4

Hi Clamps,

the issue you are seeing in Unity 5.1.1f1 (triangle on black screen) is probably due to the Graphics API settings in the Unity Player Settings - iOS:

Make sure to uncheck the "Automatic" and remove METAL and OpenGL ES 3.0 from the list of graphics API;

you must make sure that you are only using OpenGL ES 2.0

 

Gear VR with V0.6.0.1

June 29, 2015 - 11:09pm #3

This is what happened to me when I tried to run the deimagetargets-4-2-3.unitypackage using Oculus 6.0.1 on a Note 4. Unity 5.1.1.f1.

 

https://www.dropbox.com/s/8kfoy7ir7bkat1y/2015-06-30%2005.58.37.png?dl=0

Gear VR with V0.6.0.1

June 29, 2015 - 1:28pm #2

I have tried. I got some very weird behaviour.

 

First off, there are no instructions or guides or even other people who report they got it working that I can find. So if I've made a mistake, that's why.

 

I got camera showthrough to work on one side of the Note 4's display. The image it showed was very distorted.

 

When it recognised the marker, that side went black. When I took the marker away, the showthrough appeared again.

 

That's it.

Log in or register to post comments