Log in or register to post comments

imagetarget does not work on gear vr

June 17, 2015 - 7:19am #1

HI Support,

1. I did what library says and i can see it works on MAC 

2. My unity is 4.6.5 but not PRO

3. My gear vr is innovation for NOTE4, model is N9100 (CHINA)

4. I can see some errors

4.1    NullReferenceException: Object reference not set to an instance of an object
OVRCameraRig.ConfigureCamera (OVREye eye) (at Assets/OVR/Scripts/OVRCameraRig.cs:276)
OVRCameraRig.UpdateCameras () (at Assets/OVR/Scripts/OVRCameraRig.cs:149)
OVRCameraRig.LateUpdate () (at Assets/OVR/Scripts/OVRCameraRig.cs:113)
 
=>
....
        OVRDisplay.EyeRenderDesc eyeDesc = OVRManager.display.GetEyeRenderDesc(eye);

        if (!OVRManager.instance.DisableVRTracking) {
            cam.fieldOfView = eyeDesc.fov.y;
        }

 
 
4.2 DllNotFoundException: OculusPlugin
OVRManager.Awake () (at Assets/OVR/Scripts/OVRManager.cs:467)
 
 
4,.3 License error. This plugin is only supported in Unity Pro!
 
OVRManager:Awake() (at Assets/OVR/Scripts/OVRManager.cs:613)
OVRManager:Awake() (at Assets/OVR/Scripts/OVRManager.cs:468)

Do they impact on service?

 

BTW, Gear VR is not see-through glass, i am wondering how it identify image? using back camera???

 

BR

Caesar

imagetarget does not work on gear vr

June 20, 2015 - 6:06am #3

Hi Samclapton,

Thanks for your suggestion, i tried and get clear error message now

QCAR Initialization Error

"Vuforia App Key is not valid for this product please get a valid key, by logging into your account at developer.vuforia.com and choosing the right product type during project creattion."

Obviously it is caused by note 4 type. Please help to resolve it :)

 

BR

Caesar

imagetarget does not work on gear vr

June 19, 2015 - 11:39am #2

Hi

This looks like a license error (We suspect it’s a Vuforia license error. Either you are not using the right Vuforia Digital Eyewear (VDE) license, or the Note 4 model is not recognized as a compatible Eyewear device by Vuforia).

As the attached pic provides very limited readable information, can you try the following? Thank you.

1) Share some logs. You don’t need to enable anything for logging, a Vuforia license error should show up in the standard Android logcat log.

2) Try the standard DEImageTargets sample without Oculus SDK integration to verify if stereo rendering works with your license on your device. This sample is already set up for stereo out of the box and should show the same error, but in a readable form.

 

Log in or register to post comments