Log in or register to post comments

Issue with developing for Vuzix M300XL: Exception on 0_camera_thread

October 16, 2019 - 6:03am #1

Hello there,

I'm facing a problem while testing an app I've developed for Vuzix M300XL on Unity 2018.4.4f1 and Vuforia 8.3.8.

The app suddenly freezes and crashes upon starting a new scene that starting the ImageTarget scanning. The problem isn't always producible at the same scene, sometimes the scene work just fine.

The logfile as follows:

--------- beginning of crash

10-09 08:23:39.297 1718-3032/? A/libc: /usr/local/google/buildbot/src/android/ndk-release-r17/external/libcxx/../../external/libcxxabi/src/abort_message.cpp:73: abort_message: assertion "terminating with uncaught exception of type std::bad_alloc: std::bad_alloc" failed

10-09 08:23:39.298 1718-3032/? E/CRASH: signal 6 (SIGABRT), code -6 (?), fault addr --------

10-09 08:23:39.298 1718-3032/? E/CRASH: *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** ***

10-09 08:23:39.298 1718-3032/? E/CRASH: Build type 'Release', Scripting Backend 'mono', CPU 'x86'

10-09 08:23:39.298 1718-3032/? E/CRASH: Build fingerprint: 'intel/m300/vm300:6.0.1/MMB29M/201906211041:user/1.6.3'

10-09 08:23:39.298 1718-3032/? E/CRASH: Revision: '0'

10-09 08:23:39.298 1718-3032/? E/CRASH: pid: 1718, tid: 3032, name: 0_camera_thread  >>> com.gdcme.alice <<<

10-09 08:23:39.298 1718-3032/? E/CRASH:     eax 00000000  ebx 000006b6  ecx 00000bd8  edx 00000006

10-09 08:23:39.298 1718-3032/? E/CRASH:     esi d599d980  edi 0000000c

10-09 08:23:39.298 1718-3032/? E/CRASH:     xcs 00000023  xds 0000002b  xes 0000002b  xfs 00000137  xss 0000002b

10-09 08:23:39.298 1718-3032/? E/CRASH:     eip f73a2466  ebp 00000bd8  esp d599bf00  flags 00200202

10-09 08:23:39.298 1718-3032/? E/CRASH: backtrace:

10-09 08:23:39.449 1718-3032/? E/CRASH:     #00  pc 0009d466  /system/lib/libc.so (tgkill+22)

10-09 08:23:39.470 1718-1730/? E/CRASH: other thread is trapped; signum = 6

10-09 08:23:39.471 1718-1730/? E/MessageQueue: IdleHandler threw exception

    java.lang.Error: signal 6 (SIGABRT), code -6 (?), fault addr --------

    Build fingerprint: 'intel/m300/vm300:6.0.1/MMB29M/201906211041:user/1.6.3'

    Revision: '0'

    pid: 1718, tid: 3032, name: 0_camera_thread  >>> com.project.test<<<

 

        at libc.tgkill(tgkill:22)

 

looks like Camera Thread has an issue with that, as I trace out the problem.

any help?

Issue with developing for Vuzix M300XL: Exception on 0_camera_thread

October 21, 2019 - 3:10am #2

Hi,

If the issue is sporadic, there may be a timing issue when you start the new scene.

Could you please let me know if the previous scene has Vuforia content/enabled? How are you swapping scenes? ( do you by any chance init or deinit Vuforia between scenes?)

Thank you.

Vuforia Engine Support

Log in or register to post comments