Log in or register to post comments

ODG R7 and VUFORIA 6.2, GetCameraImage provides black image

July 6, 2017 - 10:05am #1

We are developing an AR application on ODG R7 and Tablet with Unity 5.5.0f3.

 

We updated our application from Vuforia 6.0 to 6.2 to correct two Issues with ODG (licence and autofocus).

With Vuforia 6.0, we obtained images from ODG R7 camera by using :

Vuforia.Image image = CameraDevice.Instance.GetCameraImage(mPixelFormat);

 

But now, with Vuforia 6.2 and ODG R7, every time we used GetCameraImage we obtain a null or black image.

We tried every pixelformat without any result.

This code works well with tablet.

 

For ODG R7, the AR Camera is configured in optic see trough.

We tried the Vuforia 6.2 sample Stereo AR with the same issue.

You can find the modified sample code as attachment.

 

Since Vuforia 6.2, it seems that GetCameraImage returns black or null images for "Optical See through".

 

Is there any workaround to get the ODG camera image with Vuforia 6.2 ?

 

Thank you.

AttachmentSize
Package icon Autofocus.zip1.61 KB
Log in or register to post comments