Log in or register to post comments

ODG R7 stereo rendering is not working

December 15, 2017 - 4:30am #1

Hello,

I'm working with ODG R-7 from 5 months. 

After upgrade Vuforia to the newest version, stereo rendering is not working correctly.

 

What should I see: 

 

 in the centre of imagetarget should be a cube.

 

What I see:

Two cubes - one is a little bit on the left, second one is a little bit to the right from the centre . There should be just one cube.

My questions:

1. How to use callibration profile in my app? It's just automatically or I need to make it somehow.

2. All setting are correct: XR setting for AR and VR are enabled, MultiThreaded Rendering is disabled, device choosen: Optical See Through.

 

What about this setting? And what is ReticleOS script? Ofc this script crash camera, but I'm wondering what is it.

 

 

 

ODG R7 stereo rendering is not working

March 27, 2018 - 9:13am #2

I'm experiencing a very similar scenario.

I have an ODG R7 that I've upgraded to the most recent OS.

In Unity 2017.3.1f1 with Vufora, I created a simple test app that places a white cube on the center of a Vufora-provided target image.

This test app works great on my Mac with the webcam. When I run the an Android build of the app on the ODG R7, I see two cubes; one to the far left, one to the far right.

As I move the glasses closer to the target image, the two cubes converge toward the center. 

I've tried recalibrating my R7 multiple times, but that has no affect on the result.

Looking for any suggestions on how to debug further.

Log in or register to post comments