Topic locked

Unity 5.3 + Eyewear Tutorial steps not working

December 25, 2015 - 5:22am #1

Hello all,

I have been following very carefully all the steps of the new tutorial:
http://developer.vuforia.com/library/articles/Solution/Integrating-Gear-VR-and-the-AR-VR-Sample-in-Unity-5-3-and-above

I have tried with Unity 5.3.1 (64bit), downgrading to 5.3.0 (64bit) and 5.3.0 (32bit) just to be sure if it was the new release.

I can execute the app in the mobile, but only the "Reticle" (the bright small circle) appears with black background, head tracking seems to work, but no camera image and no Marker recognition.

I get the following errors (Image attached)

 

Screen position out of view frustum (screen pos 545.000000, 160.499985) (Camera rect 0 0 1090 321)

transform.localScale assign attempt for 'Reticle' is not valid. Input localScale is { Infinity, Infinity, 1.000000 }.

(...)

 

Any help appreciated, I have spent a lot of hours trying different versions and approaches.

 

AttachmentSize
Image icon vuforia1.jpg271.75 KB

Unity 5.3 + Eyewear Tutorial steps not working

March 14, 2016 - 7:20am #5

Thanks guys !!!

Indeed it was the same for me, using a "Mobile" license key for the GearVR made my app work.. 

Unity 5.3 + Eyewear Tutorial steps not working

January 6, 2016 - 7:53am #4

Thanks Noffke for sharing your tip;

indeed, currently, for integrating Vuforia with GearVR (and with Cardboard too), one must use a "Mobile device" key, not an "Digital Eyewear" one.

Unity 5.3 + Eyewear Tutorial steps not working

January 6, 2016 - 6:20am #3

I was having the same issue with the Gear VR at first. After checking logs on Android device, it turned out that using an App License key set to a Digital Eyewear Device did not work. The sample app worked after I changed license key to one that targeted a Mobile device. 

Unity 5.3 + Eyewear Tutorial steps not working

December 28, 2015 - 11:56am #2

The logs that you show in the screenshot comes from the unity console while running in Play Mode; 

have you checked the device Logs when running in your Android device ? Perhaps the black camera on device might be caused by something else...

 

Topic locked