Log in or register to post comments

Unity orientation wrong, also object to target movement.

April 14, 2015 - 5:27am #1

Reposting in Digital Eyewear upon moderator request.

---------

Vuforia SDK Version: Vuforia Eyewear 4.1.3 Beta -

Description with steps to reproduce:

1. Use the eyewear calibration tool v4.1.3 to create a user profile and save it.(final test in tool shows that everything is OK)

2. Build the sample project deimagetargets-4-1-3.unitypackage with sdk eyewear 4.1.3.

3. The application when started flashes the Unity logo correctly for a second or two, then turns upside down and the application now stays that way.
  At this stage when looking at an imagetarget the teapot in scene Vuforia-1-ImageTarget moves the wrong way. If head/eyes move upward, the teapot moves upward
  and vice-versa, same thing for left and right. The convergence is OK though.

4. IF the calibration in step 1 is made on an upside down imagetarget, then in step 3 the app is still upside down but the movement is correct(teapot stays in place),
  but the convergence left/right eye is now wrong.
 

-

Development OS : Windows 7 x64, using Unity 5.0.0f4 x86 -

Mobile OS and Version: Android 4.0.4 -

Mobile Device Manufacturer and Model name: Epson Moverio BT-200 -

Do the Vuforia Sample Applications show the same behavior?: The behavior is in the sample applications, I haven't tested anything else since I don't know what's wrong.

 

--------

 

So I managed to get the sample working somewhat by removing the SampleOrientationSetter.cs script.

The application still starts the right way up for a few seconds, then turns upside down a little while, then turns the right way up again(unless it crashes at this stage).

 

 

Unity orientation wrong, also object to target movement.

April 15, 2015 - 11:47am #2

We haven't been able to reproduce what you're describing. I recommend recalibrating your device - make sure that the target is correctly oriented, with Qualcomm Vuforia in the top right corner. See: https://developer.vuforia.com/library/articles/Training/Vuforia-Calibration-App

Then try running a fresh, unmodified, DE sample project. If you're still seeing this issue PM me your email address. 

Also make sure that your project is set for Landscape Right.

Log in or register to post comments