Topic locked

vuforia Play mode

August 15, 2013 - 6:21pm #1

I am trying to test a Unity/Vuforia app in my PC using the Vuforia Play Mode. I have Unit 4.2 Pro with a team License, Android Pro, and IOS Pro. When I place the AR camera Prefab, in the Unity Inspector I get the message "Play Mode requires a Unity Pro License!". I am using Vuforia 2.6.7 (the version that it is on the download link https://developer.vuforia.com/resources/sdk/unity n August 14,2013)  Searching on the web, I saw there are some people running on the same issue, but I was unable to find any response with a solution. I am on a tight deadline and it is being painful to have to transfer the app to the mobile devices everytime I need to test a small feature change. Can somebody give me some ideas on what may be the issue for Unity/Vuforia not wanting to work on Play Mode in the PC?

vuforia Play mode

September 7, 2014 - 11:56pm #11

Concerning Win XP, as mentioned here:

https://developer.vuforia.com/resources/dev-guide/step-2-installing-vuforia-sdk

Note: Although we distribute the Vuforia SDK for the platforms listed below, support for development is limited to the Win 7 32/64-bit platform.

Win XP is not officially supported; note that Microsoft has also terminated support for Win XP (as it is now 12 years old):

http://windows.microsoft.com/en-us/windows/end-support-help

 

vuforia Play mode

September 5, 2014 - 3:19am #10

Same issues on my computer. Here is another discussion about that: https://developer.vuforia.com/forum/issues-and-bugs/webcam-play-mode-issue-unity-4#comment-2043704

vuforia Play mode not work with Unity

August 1, 2014 - 2:10am #9

Seems I am the later comer to this  Play mode  issue.   However, I encounter the same happening 1 year after the previous post.

My PC runs Win XP with SP3,  installed with Unity3D 4.5.2 pro and Vuforia ver3.  I can say the installation should have  no problem as I can verify the compilation of other unity projects even one having webcam function.   The same, I cannot make the webcam work as said when I tried to compile the  ImageTarget example downloaded from Vuforia site.   I notice that the same symptom of the warning  message -- PlayMode require a Unity Pro License ! alway appear.    I may ensure that it is not the matter of version of Unity3D. Since I also installed several different version of it.

I cannot ignor the warning message as said since it does not work any way. For the 3 teapots ImageTarget example, once I click to enter play mode. It will run to Vuforia logo screen and starting menu, once I click ok, it will display all three teapots but webcam video can never pop up.  

Could some one has idea how to solve this issue ?

Thank

Herrick

vuforia Play mode

September 5, 2013 - 10:54am #8


Here is more additional information. It seems that there may also be some issues with Vuforia as well in Windows XP. 

--------------------------------------------------------------------------------------


Hi Carolina,

Have investigated a little further. It seems that it's some internal Vuforia code triggering this, as also mentioned on e.g. https://developer.vuforia.com/forum/issues-and-bugs/unity-4-vuforia-20-play-mode-issue.

Code in question (WebCamEditor.cs line 71):

  if (!webCam.CheckNativePluginSupport())
  {
    EditorGUILayout.HelpBox("Play Mode requires a Unity Pro license!", MessageType.Warning);
  }

Which ends with call to:

  [DllImport(QCARMacros.PLATFORM_DLL)]
  private static extern int qcarCheckNativePluginSupport();

So actually it seems that either Vuforia isn't supported on Windows XP or there simply is a bug in their code on Windows XP, that makes it either fail or return an unexpected result.

Either way, this seems to only apply in the Unity Editor, as the method is returning true in play mode. So the "requires Unity Pro license!" message can probably be ignored.

Does it work in Play mode on Windows XP, or have you upgraded to a newer version of Windows in meantime?


Best regards,

Rasmus Møller Selsmark
Infrastructure Team Lead
Unity Technologies

vuforia Play mode

September 2, 2013 - 10:06am #7

Hereis what I received from the Unity Bug report. I guess I will have to upgrade to Windows 7 or 8 to solve the problem at my end in the short term...

 

Hello,

Thank you very much for additional information.

I was finally able to reproduce this issue and it turns out it is happening only in Windows XP. I have also tried to reproduce this on Windows 7, Windows 8 and OSX 10.8.4, however the issue did not appear in these operating systems. So if you have an access to a different operating system, you could work in there until this case gets resolved.

It is also a good thing that you have reported warnings in the console. This time they are not responsible for the issue (I can see them in other OS as well), however it may be different for another case. So we always appreciate information like that.

I am assigning this case to our developers now, however it is hard to forecast when it will be resolved.

Also maybe knowing this will save some of your time. We are just about to release the 4.2.1 update (it's in final stages) and this issue is still present in there, so it will not be useful to update Unity to 4.2.1 on your WinXP machine in hopes to get this issue fixed.

I hope this information will help you until this case is resolved.

Best regards,
Julius
Unity QA Team

vuforia Play mode

August 22, 2013 - 1:09pm #6

Definitely! Thank you for your help.

vuforia Play mode

August 22, 2013 - 12:46pm #5

Please report what you learn from Unity.

vuforia Play mode

August 22, 2013 - 12:28pm #4

David,

 

Here is the bug report information:

http://fogbugz.unity3d.com/default.asp?559166_8ndb9jg60fsu206n

vuforia Play mode

August 22, 2013 - 11:43am #3

David,

 

Thank you for the quick reply. Unfortunately I have not been able to make this to go away. I have tried everything you mention above, but I still cannot get the play mode to accept the camera and I get the "requires a Unity Pro license", so follow your recommendationm, I am going to post this in the Unity side. 

vuforia Play mode

August 15, 2013 - 6:28pm #2

A few things to try..

 

  • Restart Unity
  • Change the build target and restart Unity
  • Create a new project and see if the license is recognized for that one.

This is a known issue that arises from Unity's own license check. It will typically go away on its own. If you continue to have problem, please file a but report w/ Unity and PM me the ticket #.

Topic locked