Unity Play Mode Network Error

December 30, 2014 - 2:26pm #1

I was just trying out the new Vuforia Beta in Unity. I followed most of the guides and got stuck on this one:

https://developer-beta.vuforia.com/library/articles/Solution/How-To-Align-Digital-Content-on-an-Object

Every time I try to Play in the Unity Editor I get a debug message saying "QCAR Initialization Failed" and a message in the scene view saying "No network available. Please make sure you are connected to the internet".

That issue doesn't persist when I actually build the app to my phone.

Is there something I'm missing in regards to getting it to work in unity play mode?

Thanks.

Unity Play Mode Network Error

January 20, 2015 - 11:43pm #9

See also my PM.

 

Unity Play Mode Network Error

January 6, 2015 - 11:22pm #8

OK. So, if it's not an issue with your network(s), we should try to isolate the issue to its narrowest scope with a minimal repro-case,

i.e.:

 

could you try the following quick test without using any Object Reco prefab or dataset:

- create a fresh new Unity project (Unity 4.5.5 or 4.6 as you prefer)

- import the vuforia 4.0 beta unity extension package into the project, via Assets->Import...

- remove the Main Camera that Unity puts in the scene by default

- drag an ARCamera prefab into the Scene (from Assets> Qualcomm Augmented Reality > Prefabs >)

   - at this point, your scene only contains an ARCamera (and perhaps a directional light)

- copy-paste the license key into the ARCamera

- save the scene

- run Play Mode

What happens ?

 

 

Unity Play Mode Network Error

January 6, 2015 - 5:17pm #7

The mobile device and the computer share the same network. The mobile device doesn't even have a data plan, so it relies on our wifi. Nothing is blocked on our network and I even tried plugging in directly to the modem.

Still the same result.

Unity Play Mode Network Error

January 5, 2015 - 11:40pm #6

You can leave the "Dont use for play mode" checkbox unchecked; that should not play any role in this issue.

Since the issue only shows up in Play Mode but not on device, and you confirmed that you're using a valid license key,

then your computer is probably unable to reach the server for the license check, for some reasons; if you are working in a private ntwork, this might be due to your IT security blocking the URL of the license check.

Are your mobile devices and the PC connected to the same network ?

 

If the PC is on a specific network where the Vuforia URLs are blocked:

you may need to unblock  *.vuforia.com, as well as.:

  • developer.vuforia.com,
  • developer-beta.vuforia.com

Since it is on HTTPS, the port number required is 443

Unity Play Mode Network Error

January 5, 2015 - 7:06am #5

The License Key should be valid. I went through the process of creating it, copy pasting it from the License Manager into the App License Key field on the ARCamera. 

I even went through the process again just to make sure.

I'm working on Unity 4.5.5 Pro and even tried it with 4.6 Pro.

Are there any other hook ins for the License Key that I could be forgetting? Does the name of the App need to be tied into the name of the project or a project setting?

Edit: On the Web Cam behaviour script, I checked the "Don't use for play mode" box and I don't recieve the error anymore. Obviously, I don't get a camera feed either, so its kind of pointless. Is this the expected result?

Unity Play Mode Network Error

January 5, 2015 - 5:36am #4

Are you using a valid License Key taken from your beta License Manager ? 

https://developer-beta.vuforia.com/targetmanager/licenseManager/licenseListing

 

The key should be copy-pasted into the App License Key field in the ARCamera inspector; then it should work in both Play mode and device.

I just tried this with Vuforia 4.0 beta and Unity 4.6.0 and in Play Mode it worked just fine. Note that I tried with both PRO and FREE Unity licenses and it made no difference (working OK in both cases).

 

Note that you need Unity 4.5 or above to use Vuforia 4.0.

What Unity version are you using ? and which Unity license do you have (PRO, free, ...) ? 

 

Unity Play Mode Network Error

December 31, 2014 - 9:51am #3

Yep. Developing on the same computer that I'm posting from. It is hardwired into the modem.

Unity Play Mode Network Error

December 30, 2014 - 4:09pm #2

Is the computer that you're developing on connected to the internet?

Topic locked