Log in or register to post comments

combining ground plane and image target failed!

March 8, 2018 - 7:09am #1

Earlier I have completed a project which revolves around a 3D object(blender file)  and made it into a puzzle game by adding interactivity to the 3D object.I have added colliders for its child objects.Logical part is working fine except the 3D object is shaking severely giving a neightmare to me!

 

I have suspected that TrackerFound/TrackerLost functionality is toggling in or at random frames.When I searched for making the display consistant, sthought of SmartTerrain can solve my problem as it may have wide range of focus.While searching for that I knew it was deprecated and GroundPlane was introduced in Unity 2017.3 version.I have updated software with correct version and followed authentic webpages from Vuforia Development portal.

 

It proved more dangerous - a virtual havok!The capsule which I put as a child of image tracker is floating free in both TrackerFound and Tracker lost states.I have added a cube to the GroundPalneStage to check where that Ground Plane Stage is loading and wheher it is sticky or not.But The cube is also floating in the world and not settling any whaere on the flour of the AR world.I think It is following camera gyroscope and not fixed in position in the AR world.

 

SCreen structure is very simple as prescribed in those Tutoraials:

1.Directional Light

2.AR Camera:

*******Transform ffeatures

**************position:0,0,0

**************rotation:0,0,0

**************Scaling:1,1,1

3.Ground Plane Stage

*******Transform ffeatures

**************position:0,-0.467,2.048

**************rotation:0,0,0

**************Scaling:1,1,1

*******Cube1

4.Plane Finder

*******Anchor Stage = Ground Plane Stage

5.SceneImageTarget

*******Capsule1

6.Canvas

 

Why such simple content is unable to perform nicely?how could we progress even simple and nasic instructions are not giving the right result?

combining ground plane and image target failed!

March 12, 2018 - 12:26am #4

Thanks for the response!

I have attached a video showing the random transform bug as a zip file.The project scope is very very basic.We are showing  a3D object,a Truck as child of MarkerTargetImage.Entire app revolves around this 3D object.In the developing stage,I have added  a GUI text on canvas to know the TrackerFound/Lost status and finally  I put a Timer which runs only in TrackerFound state.



If my logic or design properties had any bug It would not load properly - am I right?But to my surprise, It is loading so faster,behaving right for some time and then suddenly this drift/shake/ is killing the Joy of making first successful app.

 

The same 3D object fared in VR very well and while I tried to extend it into an AR experience I am failing!

regards

hari.S.babu

AttachmentSize
Package icon app_drifting_bug_video.zip12 MB

combining ground plane and image target failed!

March 8, 2018 - 9:44pm #3

Thanks for the response!

Debug log messages are working fine.And I kept a text box to catch runtime status and events are working fine.Actually The 3D object in that old version is not disppearing completely as tracker found is ok!suddenly the size is changing,It is swinging in the mid-air leaving the default position relative to the parent transform!all the transform properties like position,rotataion and scaling is disturbing.



Just after putting this question here about recent version problem I got a doubt and checked the device android version.It is fine, above 7 and my GUI orientation and C#coding also are very basic in complexity standards!

combining ground plane and image target failed!

March 8, 2018 - 11:30am #2

Hello hariSbabu010,

You mention that you suspect tracking found and lost to be triggering at random frames, are you seeing these calls in the console? Have you tried using Extended Tracking to remedy this issue?

Please share some videos and screenshots of the issue you are facing so we can better support you.

Thanks,

Vuforia Support

Log in or register to post comments