Log in or register to post comments

Ground plane being not tracked on Android 11

January 27, 2021 - 1:09am #1

Hi.

 

I've been worked on my project including ground plane and image target. 

I could use both of them until my testing device Galaxy note 20 Ultra was in Android 10, but after updating it to Android 11, image targets are appearing well but ground planes are not.

There were only statement that smart terrain had been failed to initialize on the logcat, no other errors appeared.

Engine was activated fine, trackers were activated fine, but ground plane and the indicator had no response even in both of automatic hit tests and interactive hit tests.

I read the document that my device is not on supported list, but ground plane has been done well when it was in Android 10.

Is Android 11 is not supported yet, or any more actions are to be needed?

------EDIT

Okay, Smart Terrain is looked like the problem.

Differences between two API is whether Smart terrain is activated.

So what actions can be needed for Android 11?

Ground plane being not tracked on Android 11

May 31, 2021 - 12:23am #7

Hi @Andrey7777

Thank you for conforming.

We did see some issues with ARCore 1.23 and working on addressing them, the workaround would be to use 1.22.

Could you please confirm the ARCore version used in the project?

Thank you.

Vuforia Engine Support

Ground plane being not tracked on Android 11

May 27, 2021 - 2:46pm #6

updated to Unity 2019.4. 27f1 and earned...

Ground plane being not tracked on Android 11

May 25, 2021 - 12:33pm #5

Device model: samsung a50  a505fn\ds

Device os: Android 11

ARCore version: 3.1.3

Unity version:Unity 2019.3.3f1 (64-bit)

Vuforia Engine SDK version: 9.0.12 tried on versions 9.6.3 and 9.3.3

Hello!

I tested for more than a year on different devices and it worked everywhere ... but with the update to Android 11, I stopped seeing the floor

Ground plane being not tracked on Android 11

May 25, 2021 - 1:03am #4

Hi @Andrey7777,

Could you please confirm following:

Device model:

Device os: Android 11

ARCore version:

Unity version:

Vuforia Engine SDK version:

Thank you.

Vuforia Engin Support

Ground plane being not tracked on Android 11

May 24, 2021 - 3:30pm #3

Hello! Ground Plane stopped working on Android 11. This method did not help me

Ground plane being not tracked on Android 11

January 28, 2021 - 5:49pm #2

I solved this problem in my own.

I figured out that Smart Terrain can be activated with 'XR Plugin Management' from the package manager.

It activated 'XR Plug-in Management' setting in Player Setting and I checked the box for 'ARCore' on the Android section.

After that, everything was solved like charm.

This method wasn't even necessary until Android 10, but it looks like different in Android 11.

Log in or register to post comments