Log in or register to post comments

Ground Plane not working on Iphone 6

January 15, 2018 - 9:15am #1

I'm using Vuforia 7.0.43 in Unity 2017.2.0f3

I create an app following this tutorial:

https://library.vuforia.com/articles/Solution/ground-plane-guide.html

It works fine on unity editor, but when I uploaded to iphone 6 it show me this error on Xcode Debug:

 

ERROR/AR(2156) 2018-01-16 15:04:39: SmartTerrain is not supported on this device.

Error: SmartTerrain could not be initialized.

Could not initialize the tracker.

 

In this list, it says that Iphone 6 is supported in Vuforia 7.0.43.

https://library.vuforia.com/articles/Solution/ground-plane-supported-devices.html

 

Could you help me guys?

 

Thanks

Ground Plane not working on Iphone 6

February 3, 2018 - 4:02pm #3

I get a different error, but ground plane still does not work on my iPhone 6 Plus.  I am running iOS 11.2.5, Xcode 9.2, and Unity 2017.3 Patch 4.  Vuforia version: 7.0.47

Ground planes seem to work fine on my iPad Pro 10.5 using 2017.3.0f3 .  This is the standard release.  

According to Xcode, the crash is in UnityGfxDeviceWorker -> AddCreatedTexture() . 

I am using the Astronaut prefab.  Otherwise, the scene is the same as the Ground Plane tutorial, which as I said, works fine on the iPad.

Just for good measure, I tried using a plane 3D Capsule instead of the Astronaut.  Same error.

UPDATE: I installed 2017.3 Patch 2.  This version works fine with both iPad and iPhone.  I have not tried Patch 3, but something went wrong between Patch 2 and Patch 4.

 

 

Ground Plane not working on Iphone 6

January 15, 2018 - 9:25am #2

sorry guys, I made a mistake, my version is 7.0.36 and not 7.0.43.

Log in or register to post comments