Log in or register to post comments

GroundPlane and Rigidbody problem

May 22, 2019 - 1:23am #1

My problem (and that of some others, too) is that the Groundplane doesnt work with physics.

You put a Collider on the GroundPlane and drop an object with a Rigidbody on it. When you press Play, the Colliders on both are deactivated and the Object falls through.

In the appendix is a sample scene.

AttachmentSize
Package icon New Unity Project.zip18.52 MB

GroundPlane and Rigidbody problem

May 22, 2019 - 1:34pm #4

Hello,

Recommendation is that you review the Ground Plane feature in the Vuforia Engine Core samples. In PlayMode, an automatic emulator plane is setup. But, when running on device, we create a plane with a collider.

Please review the SetupFloor() method in Assets\SamplesResources\SceneAssets\GroundPlane\Scripts\ProductPlacement.cs for how the latter was implemented.

Thanks,

Vuforia Engine Support

 

GroundPlane and Rigidbody problem

May 22, 2019 - 11:42am #3

Hello,

Thanks @amdbuster for the repo project. This is the first time I recall seeing this type of post.

  • Which version of the Vuforia Engine SDK?
  • Observed in PlayMode? When running on device? Both?

Is this reproducible using the Vuforia Engine Core samples? Seems like your project does not follow our reference hierarchy, which makes me wonder if you're missing something fundamental.

-Vuforia Engine Support

GroundPlane and Rigidbody problem

May 22, 2019 - 5:58am #2

I have encountered a similar situation, I put a Collider and Rigidbody on a car, and I have to put the car on the ground plane, but the car just falls through.

I hope someone can provide a solution.

Thanks.

Log in or register to post comments