Log in or register to post comments

How to disable placement after first event

July 13, 2018 - 4:36am #5

In Unity using Vuforia ground plane what is the correct way to stop users moving the placement of an object every time they tap the screen.

This is with "Duplicate Stage" turned off.

I''ve seen many tutorials on ground plane placement but they all seem to stop the moment you have an object appear.

If you want to subsequently take other screen inputs from the user to modify the scene how do you stop vuforia from just constantly moving the placed object to where they tap on the screen?

 

How to disable placement after first event

July 13, 2018 - 8:34am #4

So I fixed it by just disabling the entire Plane Finder object once the object has been spawned.

Seems to work but I don't know if that is the "best" way

How to disable placement after first event

July 13, 2018 - 1:56pm #3

I do believe an alternative to this could be just to add into the OnHitTest function in the inspector view (whether you use automatic or interactive you edit the respective one) and just turn the enabled setting to false(by calling the planefinder object and the script.enabled function) of the scripts that you don't need.

How to disable placement after first event

August 16, 2018 - 11:05am #2

I'm having the same issue at the moment. How do you know when the object has been spawned?

How to disable placement after first event

October 20, 2019 - 6:22pm #1

Sorry I am new to Unity. Can you please let me know how exactly you did the disabling of entire Plane Finder object once the object was spawned?

Log in or register to post comments