Log in or register to post comments

Only black screen appeared

SDK 9.8
September 12, 2021 - 10:21pm #5

Hello! 

I built an AR application with Unity and Vuforia a month ago. And the app run well for some days. 

But after about a month,

when I open the app, only black screen appeared.(I didn't edit anything. I just have used the app.)

 

 

So, I tried the reason and I found it. After ARCore update of my devices, it is not working. 

Vuforia Ground plane and new version of Android ARCore cause the problem.

How can I solve this problem? Please help me.

SDK Version: 

Only black screen appeared

September 14, 2021 - 3:20am #4

Hey,

 

What device are you using? It might be that Google dropped support for 32-bit apps that use ARCore for that specific device. I elaborated on the ARCore specific issue here. Google also elaborated on the issue themselves and stated: "The app will stop rendering (black screen) when the app tries to start an AR session, due to a crash on the main thread while trying to load non-existent 32-bit ARCore native libraries."

I suggest that you make sure your app is built for 64-bit, which in return should fix the issue. 

 

Kind regards,

Patrick Scheper

Technical Community Manager

Only black screen appeared

September 14, 2021 - 4:13am #3

Thank you so much! pscheper!!! You are my hero!

I absolutely solved the problem. Thank you!!!!!!!!!!!!!!!!!!!!!!

Only black screen appeared

September 14, 2021 - 4:13am #2

Thank you so much! pscheper!!! You are my hero!

I absolutely solved the problem. Thank you!!!!!!!!!!!!!!!!!!!!!!

Only black screen appeared

September 15, 2021 - 7:59am #1

Happy to hear that fixed your issue! 

 

Kind regards,

Patrick

Technical Community Manager

Log in or register to post comments