Log in or register to post comments

Place content only one on Ground

December 23, 2017 - 1:28am #9

I am writing this topic for getting help on following the example from the link: https://library.vuforia.com/articles/Solution/ground-plane-guide.html. The first section is working fine for me. However, the content place as many as I tap on the screen. That is what I don't want. I want the content place only one time when user tap on the UI Button instead of the screen. because the application is allowed user to add the 3D object to the container (which is placed to the ground) and tab to select to change size, rotation, and the position.

I found the example where point 15. It was written, "If you are looking to place content once the user taps on the screen and for the". I follow each step carefully. Then success builds and tests on iPhone. The result is: I can see the tracking indicator, however when I tap on the screen, the content doesn't place on the ground.

If anyone succeeded in this example, please share your thought. Thank you.

I am using Unity3D 2017.3 patch 1, Vuforia SDK 7.36

Appreciate!

Place content only one on Ground

December 28, 2017 - 2:17am #8

You have to modify the advanced setting of the "Plane Finder Behaviour" script in the Plane Finder object. See the attachment.

AttachmentSize
Image icon Vuforia7.PNG58.91 KB

Place content only one on Ground

December 29, 2017 - 6:21pm #7

Well - looks easy enough, except there doesn't appear to be a "Plane Finder Once" object and an associated class of "DeployStageOnce" available with the library.

Also, why is the default for gameobjects that are under "Ground Plane Stage" to be visible initially before choosing a "spawn" location - resulting in 2? IMHO, everything under the "Ground Plane Stage" parent should be hidden until a user chooses a location - and there should be only one.

???

 

 

Place content only one on Ground

December 29, 2017 - 7:01pm #6

OK - I just needed to "read the manual". ;-)

 

Step 15 from here, explained everything I was missing:

https://library.vuforia.com/articles/Solution/ground-plane-guide.html

 

 

Place content only one on Ground

January 28, 2018 - 11:43pm #5

Redevilzk wrote:

You have to modify the advanced setting of the "Plane Finder Behaviour" script in the Plane Finder object. See the attachment.

 

Thank you for this help. I waste a lot of time.

Place content only one on Ground

January 30, 2018 - 1:58am #4

When i attached the DeployStageOnce script, the anchor is disabled in the start according to the script but doesn't seem to get activated once the plane is detected. Is there an error in the script?

Place content only one on Ground

January 31, 2018 - 11:13pm #3

Am I Blind or is the guide MISSING the step proposed by @Redevilzk? 

Place content only one on Ground

July 5, 2018 - 8:28am #2

The step proposed by @Redevilzk does not seem possible at this time when using Vuforia v 7.2.20 as the DeployStageOnce script has subsequently been removed.

Edit: I have come up with a fairly easy solution to the problem. That is to disable the AnchorInputListenerBehaviour and PlaneFinderBehaviour scripts once the user places the content the first time.

On the Content Positioning Behaviour script under On Content Placed > Advanced click + then drag and drop the AnchorInputListenerBehaviour script where it says None (Object) as shown in the screenshot. Then click No Function drop down and select AnchorInputListenerBehaviour > bool enabled. Make sure the checkbox is empty or OFF.

Repeat this for the PlaneFinderBehaviour script and make sure that the checkbox is OFF to disable this script On Content Positioned.

It seems like you must first disable the AnchorInputListenerBehaviour script because disabling the PlaneFinderBehaviour without disabling the AnchorInputListenerBehaviour will again enable the PlaneFinderBehaviour script. I think that the AnchorInputListenerBehaviour automatically enables the PlaneFinderBehaviour script. So best you disable both in the order stated.

The Plane Finder script is now disabled and no further content will be placed unless you enable it again. Tracking will still continue, and now that the content is placed, the user can view and move around the AR content in the scene. I hope this helps someone.

Place content only one on Ground

July 6, 2018 - 10:05am #1

The DeployStageOnce script is no longer necessary - based on Community feedback, we've updated our components to do this out of the box. As djsegler mentioned earlier, take a look at Step #15 of this guide: https://library.vuforia.com/articles/Solution/ground-plane-guide.html

If you do not see this option, it's likely because you migrated from a previous version of Vuforia. Creating the GameObjects again should make this option visible.

Log in or register to post comments