Log in or register to post comments

Stopping Ground Plane detection do not stops auto scale of placed object

May 14, 2019 - 4:52am #2

Hi,

I have placed an object using ground plane detection in unity.

Once the object is placed, I have disabled the PlaneFinder object to further stop plane detection (by gameObject.SetActive(false)).

But while looking at the same object which is already placed in the environment, the object scales automatically sometimes. I want to stop this auto scaling of object.

 

Stopping Ground Plane detection do not stops auto scale of placed object

May 14, 2019 - 11:59am #1

Hello,

Augmentation scaling and Ground Plane tracking go hand-in-hand. When the Ground Plane tracker is running it will continue to estimate the proper scale. The only way to stop the scaling is to disable the tracker - however, this also means you will lose the ability to track a plane and no more 6DoF poses will be returned by the SDK.

Expectation is that scale changes due to Ground Plane tracking will stop over time as the area is scanned. Additionally, for best Ground Plane performance, we highly recommend using devices that support ARKit or ARCore.

Thanks,

Vuforia Engine Support

Log in or register to post comments