Log in or register to post comments

AR Marker not detected Hololens RGB Camera Off

October 21, 2017 - 4:51pm #1

Hi all,

I have just reached the point where my efforts no longer bring any results therefore I strongly believe someone here will be able to give me clear answers to my problem. I use Unity 2017.2.0f3. I attached images of my project setup. For the past few days I have been trying to deploy a Unity app to Hololens. The AR Marker tracking works like a charm within Unity Game mode using my laptop webcam. Builds succeed, I run them in VS and I also succeed in deployment to Hololens. Apps work (tested with some 3d gameobjects that appear in Hololens). The major problem here is that non of used, and in Unity tested AR Markers work from Hololens environment. I researched many threads and I cannot find any proper answer to the problem. I start to think that it might be the issue of the fron RGB camera that does not show any signs of activity (white led light off) although testing live stream from the camera works with no problems. 

I would be grateful for any advice.

AttachmentSize
Image icon Capture.JPG186.44 KB
Image icon Capture2.JPG198.53 KB

AR Marker not detected Hololens RGB Camera Off

November 17, 2017 - 3:29am #11

all images have the exact size specifications. The same values entered when creating the targets and the same values when using the markers in the scene in Unity.

thanks,

huberto

AR Marker not detected Hololens RGB Camera Off

November 15, 2017 - 1:46pm #10

The issue you are describing is often a result of the printed target size and the dataset size (which was set when you uploaded your image) being mismatched. Can you double check and confirm that these are the same size?

Thanks,

-Vuforia Support

AR Marker not detected Hololens RGB Camera Off

November 12, 2017 - 1:15pm #9

Hey there,

once again thanks a million for the reply. Just like you suggested, I used Vuforia Sample with all recommended settings. I have finally managed to see the hologram although the Astronaut hologram appears in the very corner of the hololens fov and it does follow the ar marker. The hologram also appears at totally different angle than in the Unity Editor (in relation to the marker). The visible hologram in Hololens seems very jittery and not fully functioning with motion, the tracking does not seem to work to certain extent. I strongly believe that my previous custom ar marker also works, but because of this unknown bug to me, the ar marker does not appear in the vicinity of hololens FOV. Do you have any further suggestions why the holograms behave in such manner?

thanks.

AR Marker not detected Hololens RGB Camera Off

November 9, 2017 - 9:03am #8

Hey Hubert,

Have you been able to get the default Image Targets to work (any of the Mars assets)? Or is your issue only with your custom targets? Is the object you're trying to augment upon detection a child of your Image Target?

We also have the official HoloLens sample available if you want to give that a try https://developer.vuforia.com/forum/hololens/hololens-sample-now-available-unity-asset-store

Thanks,

-Vuforia Support

AR Marker not detected Hololens RGB Camera Off

November 9, 2017 - 3:57am #7

Many many thanks for the reply. I have just run the app on Hololens using your suggested build settings. I have no further luck with reading the AR Marker. 

I have no errors showing up while debugging with VS. Any idea that could get me further? 

best,

Hubert.

AR Marker not detected Hololens RGB Camera Off

October 31, 2017 - 4:28pm #6

Hello huberto,

Based on the screenshots in the initial post you made, I'm noticing two issues.

  1. You don't need the HoloLensCamera game object in your scene, you just need the ARCamera.
  2. Under XR Settings, remove Vuforia from the list of Virtual Reality SDKs, you just want Windows Mixed Reality here. You'll still want the box checked for "Vuforia Augmented Reality Supported."

This thread https://developer.vuforia.com/forum/unity/deploying-stereo-rendering-sample-hololens has steps for converting the Stereo Rendering sample into a HoloLens sample.

Let me know if you have any further difficulties.

Thanks,

-Vuforia Support

AR Marker not detected Hololens RGB Camera Off

October 27, 2017 - 8:00am #5

any ideas?

AR Marker not detected Hololens RGB Camera Off

October 25, 2017 - 12:41am #4

Sorry for such a late reply but I had no earlier possibility to test it out on Hololens. So I run debug on Remote Machine and here is what I get:

Quote:

Vuforia initialization successful



(Filename: C:\buildslave\unity\build\artifacts/generated/Metro/runtime/DebugBindings.gen.cpp Line: 51)



Found Trackable named Augmented_reality_marker with id 1



(Filename: C:\buildslave\unity\build\artifacts/generated/Metro/runtime/DebugBindings.gen.cpp Line: 51)



StartVuforia



(Filename: C:\buildslave\unity\build\artifacts/generated/Metro/runtime/DebugBindings.gen.cpp Line: 51)



Failed to get spatial stage statics - can't retrieve or interact with boundaries! Error code: '0x80040154'.

 

(Filename: C:\buildslave\unity\build\Runtime/VR/HoloLens/HoloLensWorldManager.cpp Line: 465)

AR Marker not detected Hololens RGB Camera Off

October 25, 2017 - 12:41am #3

Sorry for such a late reply but I had no earlier possibility to test it out on Hololens. So I run debug on Remote Machine and here is what I get:

Quote:

Vuforia initialization successful



(Filename: C:\buildslave\unity\build\artifacts/generated/Metro/runtime/DebugBindings.gen.cpp Line: 51)



Found Trackable named Augmented_reality_marker with id 1



(Filename: C:\buildslave\unity\build\artifacts/generated/Metro/runtime/DebugBindings.gen.cpp Line: 51)



StartVuforia



(Filename: C:\buildslave\unity\build\artifacts/generated/Metro/runtime/DebugBindings.gen.cpp Line: 51)



Failed to get spatial stage statics - can't retrieve or interact with boundaries! Error code: '0x80040154'.

 

(Filename: C:\buildslave\unity\build\Runtime/VR/HoloLens/HoloLensWorldManager.cpp Line: 465)

AR Marker not detected Hololens RGB Camera Off

October 21, 2017 - 10:55pm #2

Did you try using VS to get the info that The Mark is Lost Or Found. That could be a useful Information.

Log in or register to post comments