Log in or register to post comments

Cannot find "VuforiaMonoBehavior" with Sample Scenes 7.1.31 + Unity 2017.3.1p1

April 3, 2018 - 11:31am #1



I am currently trying to build the Mars Rover Model Target sample scene (from here: https://developer.vuforia.com/downloads/beta). I followed the set up instructions here: https://library.vuforia.com/articles/Training/Developing-Vuforia-Apps-for-HoloLens

However, when I try to press play in Unity or build the project, I get the following errors:

"Assets/Vuforia/Scripts/DefaultInitializationErrorHandler.cs(18,50): error CS0246: The type or namespace name `VuforiaMonoBehaviour' could not be found. Are you missing an assembly reference?"

"Assertion failed: Assertion failed on expression: 'm_CurrentEntriesPtr != NULL && m_IsGettingEntries'

UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)"


I am using the Sample Scenes 7.1.31, Unity 2017.3.1p1, and Visual Studio 2015 version 14.0.


Steps I've tried to resolve this:

I'm not sure why this class is missing. On another app, when I encountered this problem, I changed VuforiaMonoBehavior to just "MonoBehavior". When I pressed play, I received another error "Assets/Vuforia/Scripts/DefaultTrackableEventHandler.cs(61,57): error CS0117: `Vuforia.TrackableBehaviour.Status' does not contain a definition for `NO_POSE'. Changing NO_POSE to "NOT_FOUND" resolved this error, but I am confused about why this is as NOT_FOUND is deprecated (https://library.vuforia.com/content/vuforia-library/en/reference/unity/classVuforia_1_1TrackableBehaviour.html). This allowed me to play from unity (sometimes), but I got nullreference exceptions and overall performance of the app was very buggy and unstable.

It seems to me like I am missing some kind of update, but I'm not sure what. Any insight would be greatly appreciated!

Cannot find "VuforiaMonoBehavior" with Sample Scenes 7.1.31 + Unity 2017.3.1p1

April 5, 2018 - 2:53pm #4

I resolved this by completely uninstalling Unity, reinstalling Unity 2017.3.1p4. Then, I imported the sample scene FROM THE ASSET STORE into an empty project - for some reason, the asset store works but the package downloaded from Vuforia's website does not!


After that, I tried to build, and got a warning saying that I needed to update VS2015 to version 15.0. Version 15.0 of visual studio is VS2017. After updating to the latest version of VS2017, I got the app to build.


I am having a myriad of run time issues, but I will save those for another thread as this is focused on compiler errors.


Hope this helps!

Cannot find "VuforiaMonoBehavior" with Sample Scenes 7.1.31 + Unity 2017.3.1p1

April 5, 2018 - 8:14am #3


I have the same problem,

I managed to deploy the app by resolving those errors but when the app is launched on the Hololens, I've got a crash with this log on Visual Studio



(Filename: C:\buildslave\unity\build\artifacts/generated/Metro/runtime/DebugBindings.gen.cpp Line: 51)

Model task is null; loading alternate.

(Filename: C:\buildslave\unity\build\artifacts/generated/Metro/runtime/DebugBindings.gen.cpp Line: 51)

Le programme '[5592] New Unity Project.exe' s'est arrêté avec le code -1 (0xffffffff).

Cannot find "VuforiaMonoBehavior" with Sample Scenes 7.1.31 + Unity 2017.3.1p1

April 4, 2018 - 9:16am #2

Adding some more images to help illustrate the problem I am having? As far as I can tell, my version of Unity 2017.3.p1 has Vuforia Augmented Reality support so I am unsure why it cannot find the class VuforiaMonoBehavior.


Log in or register to post comments