Topic has a solution and is locked
Log in or register to post comments

Failed to Initialize

September 2, 2016 - 1:19pm #1
Topic solved

Hi Everyone,

I'm having trouble getting any Unity3D Vuforia sample apps to run on the Hololens. I've built from Unity and opened in VS2015 but when I run debug the app deploys no problem but after the Made with Unity screen I get Output messages of "Trackable stones lost" the "Vuforia initialization failed"  these seem to be the only errors. I have taken the unity project and diabled the HoloLensCamera and removed the ARCamera binding and tested the project locally on my surface pro. That works fine but always get the Vuforia initialization failure when starting on the HoloLens....

Win10

Unity 5.4.0f3-HTP Personal

 

Any ideas?

Failed to Initialize

January 2, 2017 - 10:25pm #10

How do you select a digital eyewear license type? In the vuforia site I am not able to select they type when creating a license.

Failed to Initialize

November 15, 2016 - 10:02pm #9

I encountered this issue this afternoon and was able to resolve it by fully uninstalling the app through the device portal, then redeploying from VS. It seemed to start after an unexpected shutdown from the battery dying while the app was running so that might have corrupted something Vuforia needs in the app's local data.

Failed to Initialize

October 27, 2016 - 1:08pm #8

Is it supposed to run in HoloLens Emulator? I think it should.

The sample doesn't run for me in the Emulator with and without debugging and with either license keys (eyeweare and mobile). All I see is "Made with Unity" splash screen. If I run with debug I see the same "Vuforia initialization failed:" as described here.

Failed to Initialize

October 25, 2016 - 5:41am #7

Figured I'd chime in here for others seeing the "trackable warnings". It's normal... As long as Vuforia initializes it'll still work once you actually gaze as your image / mark. In the log you'll see the trackable object detected once it's working properly. 

Failed to Initialize

September 13, 2016 - 8:47pm #6

Atsushi wrote:

Hi!

Click Debug > Start Without debugging or press Ctrl + F5 in Visual studio.

Please try!

Excellent tip, thanks for sharing!

Yes, if you are getting a license key error when running from Visual Studio 2015, make sure to choose Debug->Start Without Debugging option and also confirm that the license is a Digital Eyewear key type in the License Manager.

Failed to Initialize

September 9, 2016 - 10:33am #5

Hi, I actually just fixed my issue- if any one else is having the same problem, make sure you are using a Digital Eyewear license key instead of mobile device!

This might seem obvious, but the hololens in not listed in the digital eyewear category on the vuforia website and I have seen some contradicting advice as to which key to use, but the Digital Eyewear key is working for me right now

Failed to Initialize

September 9, 2016 - 7:07am #4

I have this problem to and I don't know how to debug this issue. Please, any suggestions would be greatly appreciated!!

Failed to Initialize

September 7, 2016 - 3:05am #3

I got this problem too

Failed to Initialize

September 6, 2016 - 6:08am #2

Hi!

Click Debug > Start Without debugging or press Ctrl + F5 in Visual studio.

Please try!

Log in or register to post comments