Log in or register to post comments

Hololens image target vuforia without Track device pose

June 24, 2020 - 4:29am #1

Hi :D

I am using Unity 2019.4.0f1 and Vuforia 9.2.7 deployed on Hololens 2. (Vuforia Hololens 1 + 2 sample).

When I deactivate Track device pose from Vuforia Configuration, The models aren't overlaid on top of the image target correctly (they are just elsewhere).

Is that a normal behavior ? Do I need to activate Track device pose option so that the 3D models would be overlaid on the right position with respect to the image target ?

PS: The models are overlaid far from Image target, yet I can see that the rotation of the image target rotates the models correctly.

 

Hololens image target vuforia without Track device pose

February 7, 2022 - 4:35am #6

Hey there,

 

Awesome, thank you for the update. Let me know how it goes! 

 

Kind regards,

Patrick Scheper

Technical Community Manager

Hololens image target vuforia without Track device pose

February 4, 2022 - 8:22am #5

Thanks much, but hold that thought - my tests yesterday weren't in perfect isolation. One was done in the sample project and the other was done in my own project, in a basically empty scene. I assumed there'd be no significant difference. 

Realizing I posted to soon, I did both tests in my project and saw the results I described - 55-60 FPS without Device Tracking, 26-33 FPS with. 

But then I did the same tests in the sample, and this was not the case - nearly always 60 FPS either way. 

So something's up with the project somewhere. I'll investigate more and post my findings, but you can hold off on trying to reproduce it. 

Thanks! 

Hololens image target vuforia without Track device pose

February 4, 2022 - 1:51am #4

Hey there,

 

I'll see if I can reproduce the issue early next week for you! 

 

Kind regards,

Patrick Scheper

Technical Community Manager

Hololens image target vuforia without Track device pose

February 3, 2022 - 2:57pm #3

Hi there, 

Is this still the case? I can get the marker to be placed accurately with Device Tracker enabled, but the performance is far too slow. The Hololens 2 sample scene rarely hits 30 FPS with the DEFAULT quality setting. 

Removing Device Tracking can get me to 45-50.

If it's not possible out of the box, could someone from Vuforia please briefly explain the issue, so that I may find (and share) a workaround? 

Thanks! 

Hololens image target vuforia without Track device pose

June 24, 2020 - 7:04am #2

Hi,

The Device Tracker is mandatory when using Hololens. If you not select it, you will encounter different issues, including the one faced by you.

Thank you.

Vuforia Engine Support

Log in or register to post comments