Topic locked

Known issue: Vuforia 7.5.26 does work with .NET scripting backend on UWP in Unity

October 31, 2018 - 8:57am #1

Hello,

A regression was introduced with Vuforia SDK 7.5.26 in Unity where using the .NET scripting backend will throw an exception when running a Universal Windows Platform build. This also includes HoloLens apps.

Please use the IL2CPP scripting backend instead, where this issue is not seen. We plan to fix this issue in an upcoming release.

Summary:

  • Supported Scripting Runtime Version (.NET 3.5 or .NET 4.6): The is the Unity setting that controls the version of the .NET APIs that you will be able to use in scripts. Vuforia Engine SDK 7.X only supports 3.5 at this time.
  • Supported Scripting Backend (.NET vs. IL2CPP):
    • When using .NET, scripts will be just-in-time compiled at runtime. IL2CPP does that at build time.
    • With Vuforia Engine SDK 7.5.26, we introduced a regression in .NET support on UWP.

Thanks,

Vuforia Engine Support

Topic locked