Log in or register to post comments

Missing Model Targets Sample

July 24, 2018 - 1:52pm #1

Up until recently there was a 'Hololens Model Targets' sample package available in the Downloads > Early Access section - but I notice that this page is now blank. Is that sample still available anywhere? It's quite frustrating to have these samples keep going missing with no valid replacements provided.

Upon searching the Unity asset store, I see: https://assetstore.unity.com/packages/templates/packs/vuforia-model-targets-107218   -  but this page states: "Starting with Vuforia Engine 7.2 and Unity 2018.1, the Model Target Sample has been merged into the Vuforia Core Samples. Refer to the Vuforia Core Samples for future updates to Model Target examples."

I've tried downloading the Core Samples package for Unity (from the asset store), but there is no example scene for model targets inside. There is however, an example scene for Object Recognition, but no mention of model targets in this package at all. I do see the Mars Lander model within this package, but again - there is no example scene provided in this package for model targets (or am I missing something)

Which brings me to my question: Is there currently a working Unity example scene for model targets on Hololens available?

Thanks.

AttachmentSize
Image icon MissingScene1.png194.61 KB

Missing Model Targets Sample

July 25, 2018 - 1:50pm #3

Thanks for the follow up Medabit,

I was able to fix the issue by updating my Vuforia SDK within Unity to the newest version (I had incorrectly assumed importing from the assetstore would automatically give me the most recent version of the samples package). I should mention that I did not have to update to Unity 2018 for this to work, I simply disabled > then re-enabled vuforia and it prompted me to update the SDK. After that, I simply re-imported the samples package and that solved it.

Thanks again!

Missing Model Targets Sample

July 24, 2018 - 4:10pm #2

Hello,

Apologies for the confusion about where the HoloLens sample app was initally made available (and is now gone). We posted it to the Early Access section to make it available to developers sooner than if we had posted it to the Asset Store. Once it was available on the Asset Store, we removed it from the Vuforia Developer Portal.

For the issue of the scene being missing, I believe what you're observing is the Asset Store not presenting you with the updated samples due to the version of Unity you are running. The screen shot shows you're running 2017.4.6f1 - this maps to our 7.0.57 SDK release. The updated samples, with the Model Targets scene being integrated into the Core Samples, is part of our 7.2 samples release.

Therefore, as stated in the message: "Starting with Vuforia Engine 7.2 and Unity 2018.1, the Model Target Sample has been merged into the Vuforia Core Samples."

Please note that for these updated samples to be compatible with the SDK, you will need to upgrade the SDK to the 7.2 release via Unity 2018.1 or Unity 2018.2.

To upgrade the version of Vuforia embedded in the Unity Editor, please follow these steps:

  1. Open the Unity Editor
  2. Select Window->Vuforia Configuration
    • If there is an error message about Vuforia not being enabled, please follow the instructions and restart this process
  3. If your version of Unity is eligible for a Vuforia update, you'll see a message and link to download the installer
  4. Download and extract installer executable from downloaded ZIP file
  5. Run the installer executeable
    • For Windows, select the folder that corresponds to the installed version of the Unity Editor that is eligible for the Vuforia update. Ex: C:\Program Files\Unity_2018.1.4f1
    • For Mac, select the drive
      • Note that for Mac, the installer executable will default to /Applications/Unity. This is a limitation of the Unity installer scripts. If you have multiple Unity application directories in this path, rename the target Editor version temporarily to /Applications/Unity to complete the installation
  6. Restart the same version of the Unity Editor in Step #1
  7. Verify the update in the Unity Editor via Window->Vuforia Configuration

Thanks,

Vuforia Engine Support

Log in or register to post comments