Log in or register to post comments

Tracking lag in objects created from Vuforia

March 29, 2018 - 1:24pm #1

I am using Unity version 2017.3.1f1 and Vuforia 7.1.31

I created a bare-bones Unity app for the hololens that launches a cube from a basic image target. It recognizes the image right away and the cube appears immediately--no problems there. 

I specified "Extended Tracking" to be on in the Image Target Behavior script, and it is.  I can move the target away and the cube stays.  It appears to be rock steady as long as I am about 0.5 meters away from it, rock steady.  But when I get further away, it tends to jump and blur, very sensitive to my head motion.  When I stand perfectly still, it settles down.  Looks like it's position is slow to update, unlike basic holograms created without vuforia. 

So, something is going wrong with the handoff from Vuforia to the Hololens' native tracking described in https://library.vuforia.com/articles/Training/Developing-Vuforia-Apps-for-HoloLens

I get the same behavior from a full build-out of the "Vuforia Hololens Sample" at https://assetstore.unity.com/packages/templates/packs/vuforia-hololens-sample-101553

It appears that I will need to manually set an anchor for the created object and explicitly turn off Vuforia, as described in the Jan 16th post on this thread:  https://developer.vuforia.com/forum/hololens/using-world-anchors-vuforia-extended-tracking

Please let me know if there is a faster way. Some setting, perhaps?

Tracking lag in objects created from Vuforia

December 7, 2018 - 7:47am #5

Hello,

Here are some tips/tricks that we've learned to make HoloLens tracking while using Vuforia more stable:

  • There is an inherent limitation in how accurate HoloLens can track a Model Target, which, based on our observations, can be in the order of +/- half centimeter (roughly a quarter of an inch)
  • It is VERY important to keep the Model and rendering complexity to as low as possible, so to guarantee a constant/stable 60 FPS rendering, which seems to be crucial to minimize wobbling/shaking/jitter
  • Some expedients to optimize this are:
    • Keep model triangle count well below 100K triangles (prefearrably under 50K triangles)
    • Set the light settings to "Mixed" or "Baked" (do not use "Realtime")
    • Use simple shaders (e.g. "Mobile/VertexLit" for example)
  • Enable "Depth Buffer Sharing Enabled" setting

It is also recommended to use the latest version of the Vuforia Engine SDK (7.5.26 at the time of this post) as this will take advantage of all the latest bug fixes and optimizations.

Thanks,

Vuforia Engine Support

Tracking lag in objects created from Vuforia

December 6, 2018 - 12:52pm #4

Hi,



Sorry for not replying back earlier. Did you finally had any luck with solving this problem? I still did not manage to find a good solution.

Tracking lag in objects created from Vuforia

August 31, 2018 - 5:06am #3

Hi everyone, I am having a very similar problem and was wondering if there was any news from Vuforia on this? We are running the latest Unity 2018.2.6 and latest Vuforia 7.2.23.  



What I experience is that when the image is tracked, the virtual objects is displayed on top of the marker, and that virtual object and any other virtual object displayed in the scene moves every time your head moves in a jiggly way, going back to its right position once the headset is static. This is very bad from an experience point of view. However, the virtual objects are always static if one blocks the image so that the image is not tracked. Is this happening because of the computation effort happening when the marker is being tracked? Is there any way one could disable or deactivate Vuforia doing things, once the image is detected? I just wanted to track the image once and then know its pose and then do other things which do not require tracking the image at all times.  

Tracking lag in objects created from Vuforia

April 13, 2018 - 3:06am #2

Try to use Unity 2017.2.0f3. Weirdly enough, some of the subsequent versions have major stability problems.

Log in or register to post comments