Log in or register to post comments

Adding subviews

May 14, 2014 - 11:43am #1

I'm using some code from the image targets example from within the vuforia samples app.

Whenever I try to add the eaglview as anything other than the main view of the app it basically fails.

Here's some use cases: 

The one that works is 

- (void)loadView
{
 self.view = [[TheEAGLView alloc] initWithFrame:viewFrame];
 yada yada
}

and here's what won't work:

- (void)viewDidLoad
{
//view is already loaded
[self.view addSubview:[[TheEAGLView alloc] initWithFrame:viewFrame]];
yada yada
}

If doing it that way the view shows up as a solid black rectangle. It's clearly there, but is only being populated with black, not the video preview

Anything i need to be doing to be able to add this view as a subview?

Thanks

Adding subviews

October 22, 2014 - 10:15am #3

Hi Nalin

I too am running into this addSubview bug.

While the typical use-case may be pumped through to the main window, not all are.

For some of my use-cases I do need, I repeat, need, to add the view as a subview.

This seems like a basic piece of functionality (not to mention best-practices for APIs). Is there a work around? If not when will one be implemented? This is holding me up (not to mention the rest of my company) on developing our apps.

 

Thanks in advance

Xpento

Adding subviews

May 19, 2014 - 3:38am #2

Not quite sure why you need to add it as a subview?

 

Anything i need to be doing to be able to add this view as a subview?

Not sure whether this is actually possible, as the typical use-case requires exclusive access to the video feed and this is normally pumped straight through to the main window.

 

N

Log in or register to post comments