Log in or register to post comments

App hangs on first load, but works after killing and opening the app again

October 29, 2019 - 8:52pm #1

I have been stuck on this serious issue for days now. In iOS, everytime I generate an iPA file and install the app freshly and open the unity screen, the app does not go into the AR Screen. When I kill the app and reopen, it goes into the AR Scene. This happens only on iOS. But it works if I directly build from Xcode. Happens only when I archive and generate an iPA.

We are building a native Android/ iOS app with a unity module inside it that uses Vuforia 8.3.8. These are the specs I am using currently.

Unity Plus Version : 2019.1.9f1

Vuforia : 8.3.8

iOS : 12

The app is just stuck on the Unity Splash Screen forever. I initially thought it was due to camera permission but it does not seem to be the case. Is anyone else facing this problem? It is quite urgent because we have neared production and I am running out of ideas. 

I am unable to post any logs because this happens on the archived build and xCode does not show any logs for release builds. 

App hangs on first load, but works after killing and opening the app again

November 27, 2019 - 6:21pm #4

mcotora wrote:

Hi,

The behavior is strange and without some logging it will hard to determine the cause. You mentioned that for IOS there are no logs, what about Android? Logcat should provide some logs when you import the apk and run the application. Could you please check? google street view

Thank you.

Vuforia Engine Support

Thank you so much! It's very helpful!

App hangs on first load, but works after killing and opening the app again

October 30, 2019 - 11:07pm #3

Hi mcotora

thanks for your reply. On android this completely works fine. So I don't have to debug. Its only iOS that is giving me this issue. 

App hangs on first load, but works after killing and opening the app again

October 30, 2019 - 8:15am #2

Hi,

The behavior is strange and without some logging it will hard to determine the cause. You mentioned that for IOS there are no logs, what about Android? Logcat should provide some logs when you import the apk and run the application. Could you please check?

Thank you.

Vuforia Engine Support

Log in or register to post comments