Topic locked

Black Screen

October 11, 2014 - 4:11pm #1

Hello all,

I'm Using Vuforia 3.0.9 + Unity 4.5.4

When I Build the project to iOS platform, the project builds successfuly on "xCode 5" and it installs the App on my "iphone 4S iOS 7.1.2",

but when the app opens nothing happens !! its just a black screen.

but when i build the Same project for android.. it works just perfect.

 

Any idea whats the problem ?

 

xCode Error:

Can't add component because class 'PremiumObjectFactoryStarterBehaviour' doesn't exist!
  
(Filename:  Line: 38)
 
Can't add component because class 'PremiumComponentFactoryStarterBehaviour' doesn't exist!
  
(Filename:  Line: 38)
 
QCARWrapper.Start
  
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/iPhonePlayer-armv7Generated/UnityEngineDebug.cpp Line: 49)
 
Could not initialize the tracker.
  
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/iPhonePlayer-armv7Generated/UnityEngineDebug.cpp Line: 49)
 
Could not initialize the tracker.
  
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/iPhonePlayer-armv7Generated/UnityEngineDebug.cpp Line: 49)
 
SetHint
  
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/iPhonePlayer-armv7Generated/UnityEngineDebug.cpp Line: 49)
 
2014-10-12 01:41:21.589 CamTest[1844:60b] ERROR/AR(0) 2014-10-12 01:41:21: Failed to set hint 'HINT_MAX_SIMULTANEOUS_IMAGE_TARGETS' because the ImageTracker has not been initialized.
StartQCAR
  
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/iPhonePlayer-armv7Generated/UnityEngineDebug.cpp Line: 49)
 
2014-10-12 01:41:21.807 CamTest[1844:60b] ERROR/AR(0) 2014-10-12 01:41:21: CameraDevice::getCameraCalibration(): Failed to get camera calibration because the camera is not initialized.
Trackable --- EMPTY --- lost
  
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/iPhonePlayer-armv7Generated/UnityEngineDebug.cpp Line: 49)
 
-> applicationWillResignActive()
StopQCAR
  
(Filename: /Applications/buildAgent/work/d63dfc6385190b60/artifacts/iPhonePlayer-armv7Generated/UnityEngineDebug.cpp Line: 49)

 

Black Screen

October 14, 2014 - 12:10am #4

You're welcome ;-)

Black Screen [ SOLVED ]

October 13, 2014 - 2:36pm #3

AlessandroB wrote:

Hi,

have you checked this ?

the error message appears very similar to the one discussed in this thread:

https://developer.vuforia.com/forum/unity-3-extension-technical-discussion/could-not-initialize-tracker-xcode-511-unity-450f6-vu

and with solution discussed here:
 
any chance that you're generating the Xcode project on a Windows machine (and then opening it on Mac) ?
 

 

Thank You AlessandroB, i had to get Unity on Mac and tested it and it worked perfect xD

Black Screen

October 12, 2014 - 12:36pm #2

Hi,

have you checked this ?

the error message appears very similar to the one discussed in this thread:

https://developer.vuforia.com/forum/unity-3-extension-technical-discussion/could-not-initialize-tracker-xcode-511-unity-450f6-vu

and with solution discussed here:
 
any chance that you're generating the Xcode project on a Windows machine (and then opening it on Mac) ?
 
Topic locked