Log in or register to post comments

Black Screen Issue - IOS 9.2, XCODE 7.2

January 21, 2016 - 11:46pm #1

Hi Everyone,

 

there's a problem when i'm building my project to IOS platform,

i got a black/blank camera background, but the image target and GUI works fine.

i already set the Graphics API to OpenGLES2, Scripting Backend to IL2CCP, but nothing happens, still got the black/blank camera.

 

is anyone have the solution?

thanks in advance.

 

Device : iPhone 5 (IOS 9.2)

Unity : 5.3.0f4

Xcode : 7.2

Vuforia : 5.0.10

Black Screen Issue - IOS 9.2, XCODE 7.2

August 28, 2017 - 10:27pm #8

This might not be the fix for you if the camera is working correctly in Unity editor. 

 

But it's worth double-checking:

In Vuforia Configuration -

Make sure you have Enable Video Background checked. Hope that helps!

Black Screen Issue - IOS 9.2, XCODE 7.2

August 11, 2016 - 1:41pm #7

I'm having this same issue, though it only occurs when changing levels while an object is still tracking. The screen in the next level will be black but the GUI still works. Changing levels again won't correct the issue, once the camera stops functioning it never recovers until the app is restarted.



I should also mention that it doesn't always happen. It only happens maybe 10% of the time.



I tried setting OpenGLES2 explicitly and still the same error occurs. Any further insight would be greatly appreciated!



All of my other build settings are consistent with the images above.

Black Screen Issue - IOS 9.2, XCODE 7.2

July 12, 2016 - 2:02pm #6

Hello zorn! i got the same issue as you. I follow other tutorial to integrate the unity project to an existing one, then when i run the project the black screen appears, i read the log and i found something about the cglayer and cglmetallayer... 

you found a solution???

 

Thanks!

 

Black Screen Issue - IOS 9.2, XCODE 7.2

February 2, 2016 - 6:08am #5

Hello,

I got a similar problem.

I used Unity 5.3.1f1 and XCode 7.2 for an iOS 9.2 app. Everything works perfectly fine when I launch the xcode project that Unity gave me.

But when I try to integrate the unity app inside an iOS app (using this tutorial : github.com/blitzagency/ios-unity5) the app runs, but I got a black screen in the background instead of what the camera is looking.

I suppose that there is something wrong in my iOS app in my xcode project but I can't seem to find anything.

If anyone has the same problems please share your solutions.

 

Black Screen Issue - IOS 9.2, XCODE 7.2

February 2, 2016 - 2:34am #4

Have you solved your problem with the black screen on iOS 9.2 compiled with Xcode 7.2?

I am seeing something similar: flickering between a black screen and the target video on a iOS 9.2 device but no flicker on a iOS 9.1 device, with the same code compiled and run from Xcode 7.2.

The same code, compiled with an earlier version of Xcode and deployed to the Apple App Store, works without flicker on iOS 9.2.

 

Edit: The exact same code, compiled with Xcode 6.4 and run on iOS 9.2, works without flickering -- so that is my fix for now: revert to Xcode 6.4 for this project.

Black Screen Issue - IOS 9.2, XCODE 7.2

January 25, 2016 - 7:37pm #3

wow, the sample app works fine.

well i guess there's something wrong with my shader or something. sorry, my bad.

i'll check what's wrong, thanks by the way.

Black Screen Issue - IOS 9.2, XCODE 7.2

January 25, 2016 - 2:17pm #2

Does the ImageTargets 5.0.10 sample app work okay?

Can you confirm that your settings match these:

https://developer.vuforia.com/forum/faq/unity-player-settings

 

Log in or register to post comments