Topic locked

Black screen before splash screen

May 3, 2015 - 12:11pm #1

Hi everybody!

I am searching on internet about my problem but, I am not sure exactly what I have to do.

Before I submitted my app in App Store (iOS), I tested the app on different devices through XCode (I tested on  iPad 2, iPad mini, iPhone 4s and iPhone 5s) and It ran very well. In addition, the same application I exported to Android and It runs (now) very well.

But, the problem comes when the App Store accepeted my app and I update the application in that devices before I say. And on iPad 2, iPad mini and iPhone 4s runs well. However, on the iPhone 5s appears the application but the iOS camera don't function, It appears a black screen behind the UI labels.

I have to say that iPhone 5s has allow the camera using. But I don't understand why through XCode on the same iPhone 5s runs well and then, through the App Store on the application appears black fix screen.

I am using Vuforia 4.0.105 and Unity 5.1.

I need help because I don't know what I have to do to fix that bug that only appears on iPhone 5s.

Thank you so much!!

Black screen before splash screen

May 19, 2015 - 7:04pm #6

Glad it worked. Thanks for letting us know.

Black screen before splash screen

May 19, 2015 - 12:35pm #5

I solved the problem!

I didn't understand the problem, just I updated Vuforia Unity plugin to the new version (when I builded it, that new version doesn't exist) and the application was accepted by Apple and now the app that you can download on App Store runs well on all of devices I can try.

Thank you!

 

Black screen before splash screen

May 6, 2015 - 8:31pm #4

In regards to quiting the apps, it means to remove them from running memory (not delete from device). Double-tapping Home button should show running apps and you can swipe-up to have them quit.

It would be helpful to connect iPhone 5s to computer and open Xcode and then start up app and see if there's any errors in Xcode's console.

Are you sure you've tried everything to reproduce this before it gets on the AppStore? You really need to be able to isolate and reproduce the problem locally prior to AppStore.

https://developer.vuforia.com/forum/device-support/how-report-device-issue

Black screen before splash screen

May 6, 2015 - 12:44pm #3

Yes, on the other devices the app runs okay.

It is running iOS 8.3 on all of them.

Yes, firstly on iPhone 5s it haven't permission, so I gave the permission to use the camera, but on the app appeared the black screen. However, I delete the app and I reinstalled on it. Unfortunately, It brings the same result.

All apps? I only deleted the AR app and reinstalled on the 5s. I have to delete all installed apps?

I am not sure about that, because I only fixed on the app was fine.

Thank you for reply, I expect this can be helpful for finding the solution.

Black screen before splash screen

May 5, 2015 - 3:31pm #2

A few questions:

  • Does the App Store version of app run okay on iPad 2, Mini, 4s?
  • What versions of iOS are on your 4 devices?
  • Does iPhone 5s have iOS 8 camera permission for that app?
  • Have you quit all apps on iPhone 5s and tried again?
  • Have you viewed Xcode app logs while connected to 5s?

 

Topic locked