Log in or register to post comments

Black Screen - VideoBackgroundConfig

June 15, 2021 - 7:05am #1

Hey there! 

 

I now already went through a lot of iterations of trying different combinations of either unity or vuforia. long story short: I always end up with the following error in XCode: 

 

2021-06-15 15:55:31.381487+0200 test[1268:382029] ERROR/AR(1268) 2021-06-15 15:55:31: Unable to set the RuntimeImageSource. The target width cannot be 0 or smaller.

2021-06-15 15:55:31.397905+0200 test[1268:382029] ERROR/AR(1268) 2021-06-15 15:55:31: VideoBackgroundConfig with screen size of zero received, skipping config step

 

The app opens with the unity splash and then enters a black screen. 

In the appendix is the log from XCode.

 

Unity version: 2020.3.11f1

Vuforia: 9.8.8

XCode: 12.5

iOS: 14.6

 

If I would not have to work with it I would honestly give up on it... I spent so much time googling my fingers bloody with any positive result that fixed this issue for me. 

Any working help is appreciated in the highest of forms you can imagin!

Thanks in advance

AttachmentSize
Plain text icon log.txt4.96 KB
SDK Version: 

Black Screen - VideoBackgroundConfig

June 17, 2021 - 6:51am #2

Hi,

I just tested to see if there is not a  general issue.

Tested with the Vuforia Engine Unity Core examples with:

Vuforia 9.8.8

Unity 2020.3.12f1

and XCode 12.5 

where compiled a build to run it on iPad 6 generation , which I updated to IOS 14.6

In the Xcoder build setting the maximum available was 14.5 and I selected this datecode. What is the setting in your XCode project when you check the IOS build version

So, I was able to build and to run the core examples. - Here I attached the log file from the debugging console. "log-Xcode-ipad.doc" where I did some tests - modelTarget scanned the MarsLander  and then go in the CloudReco scene and scanned Astronaut and the Fissure image targets. No problem could be detected at all.

Could you try build the Vuforia Core examples to see if you will be able to run it?

BR

Vuforia Engine Support

 

Log in or register to post comments