Log in or register to post comments

Can't load tracking datasets on unsupported device error

September 9, 2011 - 5:52am #1

Hey guys,

I just got a brand new iphone 4, and tried to run my application on it, and I get an error message that says:

Can't load tracking datasets on unsupported device
After that, there are a whole bunch of error messages, all related to tracking and "Failed to initialize QCAR", and then at the end, there's a "Camera can't stop on unsupported device"

The same application works flawlessly on my 3GS. Any ideas? Thanks!!

Re: Can't load tracking datasets on unsupported device error

September 12, 2011 - 6:47am #8

No problem, I'm glad I could help a little. :)

Re: Can't load tracking datasets on unsupported device error

September 12, 2011 - 3:17am #7
norbykov wrote:

When I transferred my old content from my 3GS to the new Iphone 4, it transferred the QCAR application too. I guess when I ran the app from xcode, it couldn't overwrite files, and was giving me the errors. So I erased the application from the phone and tried from xcode again, and it worked.

Hi norbykov,

Thanks for pursuing this, and being willing to try other things. :-)

I guess it's an Apple issue at root, but we'll add this to the list of things to watch out for.

Re: Can't load tracking datasets on unsupported device error

September 11, 2011 - 10:01am #6

Ok, so just an update, in case anyone comes across the same "problem" (it's more of a small oversight on my part, really). When I transferred my old content from my 3GS to the new Iphone 4, it transferred the QCAR application too. I guess when I ran the app from xcode, it couldn't overwrite files, and was giving me the errors. So I erased the application from the phone and tried from xcode again, and it worked. Too bad I didn't try to run it right after the transfer, to see if it's an xcode error, or if it's a transfer error, so I don't really know if it's a bug, or if it is supposed to be that way.... Thanks for the help anyway!

Re: Can't load tracking datasets on unsupported device error

September 10, 2011 - 12:42pm #5

Nope, I guess I didn't need an update since it's not working with 4.3.5 either. Really appreciate the help, but no luck so far. Power cycle I tried three times. Tried 3GS again, it's working. And I tried running the app from the home screen, and it gives me the Unity splash screen (oh, I'm using it with Unity btw), then quits. I have a hunch that maybe it's provisioning profile related, do you think it's a crazy idea? I guess it's worth a try, maybe after the phone restore some provisioning profiles got on the new phone and they're screwing things up... Will try that and report back :) Meanwhile if you have some other ideas, I'll be glad to try them. :)

Re: Can't load tracking datasets on unsupported device error

September 9, 2011 - 7:56am #4
norbykov wrote:

Although the 3GS had iOS 4.3.4 on it, and this one has 4.3.3... Guess I need to do an update...?

You shouldn't need to update, but it's worth trying all the obvious things before we have to dig deeper. Power cycle the device as well. :-)

There has been some major power outage on the West Coast of the USA which may impact some people - maybe worth trying the 3GS again to confirm (but I'm sure you have).

You could also try the running the app from the home screen, rather from Xcode, as some developers have witnessed problems with accessing the server when running from Xcode.

Re: Can't load tracking datasets on unsupported device error

September 9, 2011 - 7:35am #3
MoSR wrote:

As it's a new phone, it's probably worth checking that you can get to the internet without any connection errors, proxy web pages or data service credit issues? Maybe there's been a setup problem.

Internet is working fine on wifi. The phone has just been registered, and restored some data from the 3GS. Although the 3GS had iOS 4.3.4 on it, and this one has 4.3.3... Guess I need to do an update...?

Re: Can't load tracking datasets on unsupported device error

September 9, 2011 - 6:36am #2
norbykov wrote:

Hey guys,

I just got a brand new iphone 4, and tried to run my application on it, and I get an error message that says:

Can't load tracking datasets on unsupported device
After that, there are a whole bunch of error messages, all related to tracking and "Failed to initialize QCAR", and then at the end, there's a "Camera can't stop on unsupported device"

The same application works flawlessly on my 3GS. Any ideas? Thanks!!

As it's a new phone, it's probably worth checking that you can get to the internet without any connection errors, proxy web pages or data service credit issues? Maybe there's been a setup problem.

Log in or register to post comments