Log in or register to post comments

Dataset .dat not loaded successfully. Please redownload your dataset from the Target Management System.

July 16, 2013 - 12:36pm #1

Hi Vuforia!

We're having the same issue as noted in these other support requests:

  1. https://developer.vuforia.com/forum/ios/dataset-not-loaded-successfully-when-downloaded-documents
  2. https://developer.vuforia.com/forum/ios/dataset-not-loaded-successfully-please-redow
  3. https://developer.vuforia.com/forum/device-support/iphone-3gs-errorar112-dataset-qcardat-not-loaded-successfully-please-redownlo-0

We're working on a client project and find it really tough to accept that the best answer to come from your staff on previous requests is to wipe your device and try again. There must be a way to fix the issue in your SDK, right?

If not, can you please explain the root cause of the issue, so we can understand why iOS is to blame?

I've attached a console log and crash report from the Billaboom app in your showcase. Our client project crashes with the same exact error, but to verify that it's an issue with the SDK, I just tried another Vuforia app to be sure, and it was easily replicated.

We really appreciate any help you can offer to help us get this solved.

Thank you for your time!

AttachmentSize
Package icon Archive.zip17.54 KB

Dataset .dat not loaded successfully. Please redownload your dat

October 14, 2014 - 9:26pm #6

What do you mean by "wipe the device"?

Could you provide steps to "wipe the device" and solve this issue?

Thank you.

Dataset .dat not loaded successfully. Please redownload your dat

July 18, 2013 - 8:33am #5

It has happened on 2 devices, so far. Both iPhone 5 with iOS 6.1.4.

Per the other support requests linked in my original post, the only common thread I see is that it happens on phones. I didn't see any instance of it happening on iPads.

Thanks for the quick reply!

Dataset .dat not loaded successfully. Please redownload your dat

July 18, 2013 - 8:28am #4

Can I just check whether this is device specific?

If so, how many devices display this issue?

N

Dataset .dat not loaded successfully. Please redownload your dat

July 18, 2013 - 8:22am #3

Hi Nalin,

I didn't think they were any different since the dataset error is the exact same and I'm not sure what additional details to provide, beyond the console log and crash report provided in my original post.

For any Vuforia based app, the app never makes it to the camera view and crashes while trying to load the targets, and the error is always the same. The same applications work fine on most other devices, although one of my teammtes has been able to reproduce the issue with multiple Vuforia apps, however after a couple of tries reinstalling those apps, that device ended up working again error-free, which really makes no sense.

I still don't understand how wiping the device is the best answer available, considering it's got to be something to do with the SDK code that's causing the issue, despite the fact that it's intermittent. It would be nice if the Vuforia team could figure out the root cause, instead of settling on "wipe your device". If the keychain was corrupted, it sure seems like that should affect other apps on the device, instead of just Vuforia apps, and you all don't seem very confident in your replies and it feels more like you have given up trying to fix the issue.

Any additional help you can offer is greatly appreciated though.

Thanks for your time either way!

Dataset .dat not loaded successfully. Please redownload your dat

July 17, 2013 - 5:22am #2

Hi HDITrae,

Rather than refer to those existing threads where the causes of datasets not loading are different, it would be better if you could accurately describe the problems you are facing.

There have been cases reported whereby a device simply fails to load a dataset from any Vuforia app and the only solution is to wipe the device, possibly due to the fact that the device keychain might have become corrupted - the cause of which is unclear. 

If you think this is the problem then have you tried running the application on other devices?

 

N

Log in or register to post comments