Log in or register to post comments

Dataset file not found

March 10, 2012 - 9:06am #1

I'm creating my first AR app based off of the example provided.
I included my tracker .xml file and .dat file that I downloaded from my Trackables. Here is the print out from the log:
It seems it can't load the tracker info, but I'm sure it is there.

Any help would be much appreciated.

2012-03-10 12:00:55.581 OreoAR[4350:410b] INFO/AR(4350) 2012-03-10 12:00:55: ImageTracker: Successfully created dataset
2012-03-10 12:00:55.585 OreoAR[4350:410b] ERROR/AR(4350) 2012-03-10 12:00:55: Dataset file OreoDemo1.xml not found
2012-03-10 12:00:55.588 OreoAR[4350:410b] ERROR/AR(4350) 2012-03-10 12:00:55: DetectorNFT4_DataSet::beginModify(): Dataset is already in modify state
2012-03-10 12:00:55.590 OreoAR[4350:410b] ERROR/AR(4350) 2012-03-10 12:00:55: Failed to load dataset 'OreoDemo1.xml'.
2012-03-10 12:00:55.593 OreoAR[4350:410b] Failed to load Oreo Dataset

Dataset file not found

March 21, 2014 - 3:14am #10

Please avoid multiple posts for the same problem.

Create a new thread and clearly explain the issue.

N

Dataset file not found

March 20, 2014 - 12:06pm #9

i have the same problem in xcode, but the links are dead....
has anybody a new link? or explanation how ti works?

Dataset file not found

July 23, 2012 - 6:45am #8

Great - glad problem is sorted :)

N

Dataset file not found

July 23, 2012 - 6:21am #7

I am doing mistake while adding xml file in project checkmark for Add to Target is not checked.

Now it worked.

Thanks for your help NalinS.

Dataset file not found

July 23, 2012 - 6:12am #6

This ought to work.

Two questions:

  • Have you checked copybundleresources to check that the files are actually in the bundle? 
  • What does the XCode log say?

N

Dataset file not found

July 23, 2012 - 4:39am #5

thanks NalinS,

I am trying to edit VideoPlayback example. I am just trying to use my image.

For new images i created new xml & dat file that file are at the same location where old one are present(which are come from demo).

and I changed file name in app delegate like this:


    // Provide a list of targets we're expecting - the first in the list is the default

    [qUtils addTargetName:@"teplate1" atPath:@"teplate1.xml"];


still application giving same error.

 

Thanks.

 

Dataset file not found

July 23, 2012 - 4:01am #4

Hi onkar11

The only reason this message comes up is that it cannot find the .dat and .xml files.

If these are in the bundle then you need to make sure they actually are there - see this thread for more details:

iOS Failed to load dataset - copy bundle resources

and this:

iOS Copy Bundle Resources - Won't Recognize Trackable | Vuforia

Or on the other hand if you are downloading these files and storing them in your documents directory then you might need to look here:

iOS - how to use STORAGE_ABSOLUTE

HTH

Dataset file not found

July 23, 2012 - 3:24am #3

Hi,

I am having same problem as you told. 

You found any solution/reason for that??

Re: Dataset file not found

March 12, 2012 - 8:44am #2

Hi Supereid86

Since it states 'not found' I can only offer suggestions such as:

* Check the case of the filenames
* Check that the files are in the root of the app bundle (in Xcode and in the package generated)

Log in or register to post comments