Log in or register to post comments

Error in XCode distribution

July 10, 2015 - 2:56am #1

Hi!

Sorry for my English.

I have a problem with my application. My application is made in Unity with Vuforia.

When I try to distribute the application and I go to Product->Archive.....Submit....I get this error:

 

"<IDEDistributionIssue: severity(error), error(Error Domain=ITunesSoftwareServiceErrorDomain Code=-20008 \"The package could not be unpacked because of the following error: Unable to extract archive.  Please make sure /var/folders/my/gsjmwv4d1pv_w48mb9j82lw00000gn/T/XCodeDistPipeline.Doe/Unity-iPhone.ipa is a valid zip or ipa archive.\" UserInfo=0x7fd27952d0b0 {NSLocalizedDescription=The package could not be unpacked because of the following error: Unable to extract archive.  Please make sure /var/folders/my/gsjmwv4d1pv_w48mb9j82lw00000gn/T/XCodeDistPipeline.Doe/Unity-iPhone.ipa is a valid zip or ipa archive., NSLocalizedFailureReason=Unable to validate your application.})>"

 

What is the problem?

 

Thanks!

Error in XCode distribution

July 29, 2015 - 6:52am #5

Sorry, in english?

Lo siento, ¿en español?

Error in XCode distribution

July 28, 2015 - 11:19pm #4

我和你一样的错误,真机测试没总是就是不能发布IPA,发布就出现下面的错误

  "<IDEDistributionIssue: severity(error), error(Error Domain=ITunesSoftwareServiceErrorDomain Code=-20008 \"The package could not be unpacked because of the following error: Unable to extract archive.  Please make sure /var/folders/4c/56sx5ndd0mdgxgzf3yclls100000gn/T/XCodeDistPipeline.9wI/Unity-iPhone.ipa is a valid zip or ipa archive.\" UserInfo=0x7fdd5818fe00 {NSLocalizedDescription=The package could not be unpacked because of the following error: Unable to extract archive.  Please make sure /var/folders/4c/56sx5ndd0mdgxgzf3yclls100000gn/T/XCodeDistPipeline.9wI/Unity-iPhone.ipa is a valid zip or ipa archive., NSLocalizedFailureReason=Unable to validate your application.})>"
)

Error in XCode distribution

July 14, 2015 - 8:39pm #3

I had the same problem and yes, it was an issue related to QCARWrapper.bundle. But for knowledge for everyone (I had to search the solution in other post) you have to set this bundle to "Standalone" and "Editor", and not in "Any Plataform" or "iOS" or "Android", not matter that your app is for iOS or Adroid.

The solution is here: https://developer.vuforia.com/forum/ios/qcarwrapperbundle-codesign-failed-xcode

Thanks for the path!

Error in XCode distribution

July 10, 2015 - 5:57am #2

The problem was the Vuforia folder QCARWrapper.bundle

 

Thanks!

 

 

Log in or register to post comments