Log in or register to post comments

ETA on 'Black screen when switching scenes' issue?

November 28, 2020 - 12:43pm #1

Last week, there was an issue tagged in the 'Known Issues' section of the patch notes (screenshot attached).  We have encountered this glitch and while I am working on a work-around I was hoping that it would be flat out fixed soon.



I look today and I note that that line has been removed from the 'Known issues'.



Has this already been fixed (perhaps on Apple's end?  It seems related to upgrading to 14.2)  If it hasn't been resolved why has it been removed from 'Known issues'?  (EDIT:  I stand corrected - I was looking in iOS known issues, not Unity known issues.  It is still there)



This was a major problem for us.  We had an exhibition launch in Toronto and while things seemed fine during the week we tested the event, right after launch we had ALL kinds of problems with black screens ALL on iOS.  Our clients reported having upgraded their phones to 14.2 during that week.  Having seen this in the patch notes had me a little relieved, but I now see that has been removed.



Our clients are NOT happy about this and it has been a huge hamper in our working relationship.  Things were fine before the launch and then all of a sudden this was happening with no changes made to the app itself.



Please advise on an ETA or a work-around I can do.  I've already created a delay of 15 seconds between menu load and AR CAM scene-change so that if the user tries to go straight to the AR CAM from the menu (rather than browsing the menu) it'll create more of a delay to prevent rapid-switching.

AttachmentSize
Image icon Capture.JPG68.97 KB

ETA on 'Black screen when switching scenes' issue?

January 16, 2021 - 10:48am #11

The app repository isn't in a state that's easy to transfer at the moment (it's in separate submodulees that need different permissions)  We are going to revise this in februrary.  If it comes to that, please let me know how we can best get the repo to your team (maybe we can add your GitHub account to our permissions list?)



In the meantime - we found a user-driven work around.  If the app gets minimized and then you switch back to it, the image clears itself.  

I strongly suspect that you have code that triggers something when the app recovers after being minimized.  Is there a way for me to call that function directly after a few seconds?  If so I may be able to trigger whatever refreshes it automatically to fix the issue.  (We are already calling OnSurfaceChange(screen.width, screen.height)  That was an early fix that was needed for Android way back several years ago)

ETA on 'Black screen when switching scenes' issue?

January 7, 2021 - 2:27am #10

Hi,

Unfortunately I don't have any update from the dev team.

As next that we would recommend would be to share the Unity project with us to investigate further the issue.

Would this be possible?

Thank you.

Vuforia Engine Support

ETA on 'Black screen when switching scenes' issue?

January 6, 2021 - 10:46am #9

We have found a work-around that clears the issue.  If you tap the home button to minimize the app and then pull it back up again the camera works fine.  I wonder if there is a way for us to trigger the same effect in code.

 

Part of me is wondering if the 'delayed android screen fix' that we implemented a long time ago will work, but I thought I would at least report this discovery.

ETA on 'Black screen when switching scenes' issue?

December 16, 2020 - 9:29am #8

@mcotora - This doesn't seem to have helped much.  



I should point out that 'black screen' is actually slightly inaccurate.  What is actually happening is the camera freezes.  Usually it does so immediately before the camera initializes (causing it to actually be black), but sometimes the camera will start and it will freeze the image of what it was pointing at in the first fraction of a second.



The client did find a strange work around that seems to get the camera working again by turning off the phone screen.  Hopefully that helps you diagnose the issue.



Here was the exact response;

 

Hi Justin, At first, it seemed to be working better. Testing, I had only gotten the black screen twice with the camera working the majority of the time. However, I just went to test again and opened the camera 5 times, each time either a black screen or the camera opens then freezes.

HOWEVER, I do think I've discovered a manual fix that's been working for me. If I turn my phone screen off then back on after getting the black camera screen, the camera starts working again.

ETA on 'Black screen when switching scenes' issue?

December 14, 2020 - 10:28pm #7

I am happy to try any hack that will get this working for our clients.  Thank you.  I will report the results after we get them to try it.



Some users reported having black screen the first time they open it - even closing an reopening doesn't work.  That said I will see if this helps in any way.

ETA on 'Black screen when switching scenes' issue?

December 14, 2020 - 6:43am #6

Hi,

I've tested the app on an iphone 8 and I was able to reproduce the issue. In my tests I noticed that it works the first time afterwards switching to the menu and back to the AR scene results in a black screen.

It seems that closing and opening the app does the trick.

Currently I do not have an ETA for the bug fix, this being said, taking my findings into consideration, I believe that we could work around the issue by simply stopping/starting the Vuforia when accessing the menu/AR Scene.

Could you please try running VuforiaBehaviour.Instance.enabled = false before switching to the Menu scene?

I understand that this may be a 'hack' but in order to get the app working as expected, it is worth givint it a try.

Thank you for your understanding.

Vuforia Engine Support

ETA on 'Black screen when switching scenes' issue?

December 8, 2020 - 11:51am #5

I have these errors reported on my Analytics (where I submit all Error messages thrown by the app)  Are they relevant at all?

 

'Screen position out of view frustrum' suggests maybe the screen panel isn't actually visible to the AR CAM, which could result in a black screen.  I have been unable to reproduce this in the editor.

AttachmentSize
Image icon iOSError NovDec.JPG71.52 KB

ETA on 'Black screen when switching scenes' issue?

December 6, 2020 - 8:46am #4

I want to stress that this was working fine prior to mid-November (aside from my old iPad, which I'm not convinced is related).  We have an exhibition in Toronto right now, partnered with Toronto Junction BIA.  Shortly after exhibition launch, two of our main contacts with the BIA have started having issues with this - and it seems to coincide with them upgrading their phones to iOS 14.2, and they have had lots of reports on their end about this.  This has put a strain on our business relationship, because they are understandably not happy.



Our small team here in Calgary has not replicated this on any iOS 14.2 devices we've tried it on, but we don't have a wide deployment here as our event isn't starting until January.

ETA on 'Black screen when switching scenes' issue?

December 6, 2020 - 8:41am #3

Thanks for responding.



The current live version was built with Unity 2019.4.8 and Vuforia 9.4.6

I have also tried a TestFlight build using Unity 2019.4.15 and Vuforia 9.6.3 which had the same issues.



The two people I've had direct communication with with this issue had iPhone 7 and iPhone 8.  Neither had this issue until they upgraded to iOS 14.2.  There are other reports but I don't know the specifics of their devices.



I've had a situation that feels similar on my old iPad Mini (I think it's 2nd generation) that only goes up to iOS 12.  I was able to run the Vuforia Core samples on that device.  My attempt at overwriting the settings in my app with the Vuforia Core samples was a disaster and I was unable to build it, so I seem to be unable to replicate that environment in my app.  I'm also not sure if this is exactly the same issue.

If it helps your team at all, the app is called Augle, and they can download it from the App Store.  The issue is repeatable on some (but not all!) iOS devices by going into the AR CAM button (bottom middle) and back out.  It seems to happen more than 75% of the time for people that suffer from it.  Its intermittent.  After several attempts they are able to get into the AR CAM.

Based on the patch notes that say that this is caused by 'successive and rapid calls to Scene.Load' I did try creating a forced 15 second delay between Main Menu load and AR CAM load, this did not alleviate the issue.

ETA on 'Black screen when switching scenes' issue?

December 3, 2020 - 7:51am #2

Hi,

Will ask the dev team for an update on this and update the thread.

Could you please also confirm which version of the SDK are you using?

Thank you.

Vuforia Engine Support

Log in or register to post comments