Log in or register to post comments

Fail to load local dataset on ios

September 12, 2013 - 2:02am #1

Hello,

u have updated an existing dataset

theDataSet->load retrun false..

the app loads all AR files except this specific AR set which was modified yesterday and redownloaded from the TMS.

In android , the dataset is loaded successfuly..

how can i understand what's the issue since your lib does not return any information about the failure

 

i'm attaching the data set files

https://dl.dropboxusercontent.com/u/13431688/temp/bad.xml

https://dl.dropboxusercontent.com/u/13431688/temp/bad.dat

thanks

 

Fail to load local dataset on ios

September 13, 2013 - 2:28am #8

You need to upgrade to the latest SDK - the TMS should work with this.

N

Fail to load local dataset on ios

September 12, 2013 - 10:24am #7

 

The incompatibility is with QCAR lib 2.0.32 (Released in Apr-May/2013).

 

Is this lib support AR files created from the current TMS?

It currently does not enable to run AR files created in the past days.

Please check,

 

Best regards,

Aric

Fail to load local dataset on ios

September 12, 2013 - 10:08am #6

Fail to load local dataset on ios

September 12, 2013 - 10:06am #5

ok,

the qcar we used in the appstore is 2.x , 2 version before the current one (with the cloud support)

so it should suppport this kind of local data set files.

 

what i understand ,

if i create a new local data set it work on my appstore version

if i update an 1month old local dataset it does not work on my appstore version..

please check it out , you might have backward compatibility issues.

 

Thank you very much for your quick response and help!

 

 

 

Fail to load local dataset on ios

September 12, 2013 - 3:57am #4

a - no, not normally.  However in this case if you have an existing app, and you are creating new datasets for it to download, then you will need to update it.

b - the Target Manager has been updated and its output is no longer compatible with 1.x applications

N

Fail to load local dataset on ios

September 12, 2013 - 3:26am #3

Thanks for the quick respone.

I updated the lib and it works,

 

what i dont understand is :

 

a. if i want to update AR of an existing appstore app i also need to republish the app to the store ? why is that ? my app get new dataset update from my server..

b. if i create a new dataset it works with the old qcar build but if i update old dataset it does not work on old qcar build ?

 

 

 

Fail to load local dataset on ios

September 12, 2013 - 2:49am #2

The links your provide do not seem to work.

Are you using a previous version of the SDK?

 

 

Have you upgraded the dataset recently?  If so then you will most likely have to upgrade to the latest Vuforia SDK.

 

N

 
Log in or register to post comments