Log in or register to post comments

iOS 10 iPhone 6 - Crash when camera starting up

October 24, 2016 - 7:16am #1

So I have a Vuforia app running perfectly on many versions of Android.

I have ported the Unity project to a MAC running Unity & XCode.

App compiles and deploys correctly to an iPad Air2 and iPhone 6 both running iOS 10.

App on iPad works no problem.

App on iPhone 6 crashes as soon as the camera is initialised by Vuforia.

 

I have tried both Mono 2.x and IL2CPP both cause the same issue.

I have also set the Optimization modes to FAST and FASTEST / SMALLEST.

 

Does anyone have any ideas on how to fix this?

 

Unity: 5.4.1f1

iOS: 10

iPhone 6

iPad Air2

iOS 10 iPhone 6 - Crash when camera starting up

September 21, 2017 - 1:30pm #6

Have you set the NSCameraUsageDescription key in the plist?  This key used to be "recommended" but is now required, and the app will crash if you access the camera without it.

https://developer.apple.com/library/content/documentation/General/Reference/InfoPlistKeyReference/Articles/CocoaKeys.html#//apple_ref/doc/uid/TP40009251-SW24

 

 

iOS 10 iPhone 6 - Crash when camera starting up

September 18, 2017 - 6:51am #5

Still no support? I see many posts about crashing on iOS 10 on some device and never any answer.



Some users (iphone5 and iphone6 - ios 10.3+) of my app having issues where they crash on camera initialised by Vuforia. I can't reproduce the problem on the devices i have, so impossible to see any logs.



Did you find out what make your app crashs?





Using : Unity : 5.6.1f1  / Vuforia 6.2.10  / mostly tested on iphone 6s (10.3+)

iOS 10 iPhone 6 - Crash when camera starting up

August 1, 2017 - 10:46pm #4

@TROIT,



I am facing the exact same issue. 

I have built the app in unity, and created apk's for Android - it works like a charm.

Built it in xcode, works really well in Ipad but as soon as the camera opens, the app crashes in iPhones, have tested it in iphone 6S and 5S.



Were you able to fix your problem? Can you help

iOS 10 iPhone 6 - Crash when camera starting up

October 29, 2016 - 3:04am #3

We have similar problem where on iPhone 5S ios 10 camera not working. App worked fine till ios 10 update came out, but now on iPhone 5S app just not works. And it looks like there is some graphical bug also. On every other apple device app works fine.

Here is link to xcode logfile https://docs.google.com/document/d/1rDL995ItqFjy7i3LwmX4SbdkX4UQGM03oVsg-CrB094/edit?usp=sharing

And here is video of how our app now behaves https://drive.google.com/file/d/0B1WrqlA12c29a3dvdVRUbnFFYTg/view?usp=sharing

Normally scanning line just runs up and down, but now it just duplicates it self and scanning is not working, all user interface is not usable. 

We are using vuforia-unity-6-0-117 version (we added scanning line by yourself), Unity3D pro 5.4.2f2, xcode 8.1. 

Just to mention that we added camera use permission in xcode, otherwise app would not work on other devices. Maybe you have some suggestions what we can do to resolve this problem, because we already running out of ideas how to resolve this iphone 5s problem.

iOS 10 iPhone 6 - Crash when camera starting up

October 26, 2016 - 6:51pm #2

Unity 5.4.1p1 recommended for iOS 10:

https://developer.vuforia.com/forum/faq/unity-player-settings

What error is in the logs?

Log in or register to post comments