Log in or register to post comments

iOS 8 Freeze

September 16, 2014 - 2:58am #1

Hi everyone,

I'm testing my app with iOS 8 and there are several issues. The scanning is slower and after different targets OpenGL stop to draw the background, and also the the lines of Vuforia Clouds stop working.

The Image tracking continuos to work (I can log the image that it finds..) and the app is usable in other parts (UI controls, etc..).

Other times, using the method pauseAR the app freeze itself without a crash or logs o something.

Have you experienced similar issues with iOS 8?

Thanks

iOS 8 Freeze

October 1, 2014 - 8:58am #11

:-)

iOS 8 Freeze

October 1, 2014 - 7:01am #10

Ahw!! Thanks!!!! 

It actually saves my a** 

 

Thanks AlessandroB

iOS 8 Freeze

September 30, 2014 - 11:00am #9

Hey ortofon,

have you already checked this article?

https://developer.vuforia.com/forum/ios/ios-8-xcode-6-and-vuforia-30-compatibility

iOS8 introduces camera access check; if the camera access is not granted to the App by the user (the first time the app is run), then the camera view will be black (see article for more details).

 

iOS 8 Freeze

September 30, 2014 - 9:55am #8

Same here, Unity 4.5.4, Vuforia 3.0.9, Xcode6, IOS8 ... black screen in place of the camera image.

On IOS 7, it is working fine.

Still no solution to give to the client who already paid the cloud service :/

 

iOS 8 Freeze

September 23, 2014 - 1:49pm #7

Hi F9,

I'm not sure I fully understand what you are doing; the Vuforia samples call onPause (actually the "pauseAR" method) by using a UINotification witht his code:

[[NSNotificationCenter defaultCenter]

     addObserver:self

     selector:@selector(pauseAR)

     name:UIApplicationWillResignActiveNotification

     object:nil];

 

This works on iOS8 (as well as in previous versions of iOS).

 

Can you describe the issue a bit more in detail and with exact steps to to reproduce it ?

 

iOS 8 Freeze

September 22, 2014 - 8:49am #6

After some experiment I've found that the onPause func of vuforia cannot be handled on main thread.

I can use in background, but the downside is that several times it doesn't work and the app keep recognizing the targets. Another problem is that it pause the camera and it cannot start with onResume func.

I've made test and both with deviceDB and cloud solution have the same problems.

Is going vuforia to release a new versione fully compatible with iOS8 (and hopefully with Swift)?

 

Thanks.

iOS 8 Freeze

September 19, 2014 - 12:18am #5

Concerning this:

 jsut tested all our apps currently on the AppStore and the camera texture sometimes works fine and some not (all black).

Using unity 4.5.3, Xcode 6 and iOS8 SDK.

See reply here:

https://developer.vuforia.com/forum/unity-3-extension-technical-discussion/ios-app-rejection-no-camera-detected-after-allowing-cam#comment-2043972

and also check out the sticky here:

https://developer.vuforia.com/forum/ios/ios-8-xcode-6-and-vuforia-30-compatibility

 

iOS 8 Freeze

September 19, 2014 - 12:06am #4

 

Hi iguana02, specifically for this issue you mention:

Note, Unity released 4.5.4 and Looks like Vuforia doesn't work, looks like some postprocessing error.

see article here:

https://developer.vuforia.com/forum/unity-3-extension-technical-discussion/unity-454-and-vuforia-ios

 

 

iOS 8 Freeze

September 18, 2014 - 4:48pm #3

Hi, same problem here. I jsut tested all our apps currently on the AppStore and the camera texture sometimes works fine and some not (all black).

Using unity 4.5.3, Xcode 6 and iOS8 SDK.

 

Note, Unity released 4.5.4 and Looks like Vuforia doesn't work, looks like some postprocessing error.

iOS 8 Freeze

September 16, 2014 - 11:04am #2

Hi,

 

I've got the same issues running my app on an iPhone 4s with iOS 8 GM. Pushing/Poping sub viewcontrollers works on iOS 7, but the camera freezes when poping back to the cameraview under iOS 8 (not everytime, but almost every second/third time). I did not find a solution yet. Perhaps the only way to fix that is to stop the ar-framework before pushing another view and reinit/restart it after the pop.

 

Upgrade from QCAR 3.0.5 to QCAR 3.0.9 does not help and it's not a matter of XCODE 5 or XCODE 6.

 

Greetings,

bodeme

Log in or register to post comments