Log in or register to post comments

IOS 8, Unity 4.5.4/4.5.5 Camera works only in first scene

October 20, 2014 - 2:53am #1

Hello community,

For updating our app to IOS8, we updated Unity to 4.5.5 and Vuforia to 3.0.9 (Unity Extension).
We did all the necessary things to access the camera in IOS8 and our first loaded AR scene works absolutely perfect.
But when we start another AR scene, the camera won't work anymore. It displays the last frame of the camera from the first scene and freezes there.
However, tracking works in the background. In the console I can see that vuforia finds the target and the scene seems to be loading (I can hear sounds).

Camera Accessability should be fine. It's allowed inside the iPad settings.

We built our own views inside the Unity-iPhone project. when a native view is loaded, we are loading an empty unity scene and pause unity in the background(FPS to 1 and TimeScale to 0) to decrease cpu load. when loading the next unity scene, we resume back to normal fps and timescale. could this have something to do with my problem?

Hope that somebody has similar problems and maybe a solution. In IOS7 this worked like a charme for us..

Have a nice day!
Robert

IOS 8, Unity 4.5.4/4.5.5 Camera works only in first scene

November 3, 2014 - 2:11am #2

Hello,

today I tried the following:

I removed the AR camera from my AR scenes and added an AR camera to the empty scene (used for receiving LoadLevel Messages from iOS) with activated "keepAlive".

Unfortunately nothing changed. My first scene works fine, so the AR camera seemed to be kept alive from the empty scene but the second scene doesn't render. there is just the last camera frame from the first scene rendered..

Thats really frustrating. Do you know when the Vuforia 3.0.10 update will be released? and will there be bugfixes regarding openGL/rendering issues and stuff like that?

Best regards,

Robert

Log in or register to post comments