Log in or register to post comments

iOS build failed

March 12, 2018 - 3:38am #1

Hello frends!

I'm trying to build an iOS project in Xcode 9.3 / Unity 2017.3 with Vuforia 7.0.3. I got these errors:


 

 

Undefined symbols for architecture arm64:

  "Vuforia::SmartTerrain::getClassType()", referenced from:

      _smartTerrain_hitTest in libVuforiaWrapper.a(SmartTerrain.o)

      _smartTerrain_getHitTestResults in libVuforiaWrapper.a(SmartTerrain.o)

  "Vuforia::DiagnosticsRecorder::addScreenshot(char const*, Vuforia::STORAGE_TYPE)", referenced from:

      _diagnosticsRecorderAddScreenshot in libVuforiaWrapper.a(DiagnosticsRecorder.o)

  "Vuforia::Tool::setRotationFromQuaternion(Vuforia::Matrix34F&, Vuforia::Vec4F const&)", referenced from:

      _positionalDeviceTracker_CreateAnchorFromPose in libVuforiaWrapper.a(DeviceTracker.o)

  "Vuforia::DiagnosticsRecorder::clearAll()", referenced from:

      _diagnosticsRecorderClearAll in libVuforiaWrapper.a(DiagnosticsRecorder.o)

  "Vuforia::DiagnosticsRecorder::clearUnpinned()", referenced from:

      _diagnosticsRecorderClearUnpinned in libVuforiaWrapper.a(DiagnosticsRecorder.o)

  "Vuforia::DiagnosticsRecorder::addUserComment(char const*)", referenced from:

      _diagnosticsRecorderAddUserComment in libVuforiaWrapper.a(DiagnosticsRecorder.o)

  "Vuforia::DiagnosticsRecorder::stop()", referenced from:

      _diagnosticsRecorderStop in libVuforiaWrapper.a(DiagnosticsRecorder.o)

  "Vuforia::ModelTarget::getClassType()", referenced from:

      findModelTarget(void*, char const*) in libVuforiaWrapper.a(ModelTarget.o)

  "Vuforia::DiagnosticsRecorder::init(char const*, Vuforia::STORAGE_TYPE)", referenced from:

      _diagnosticsRecorderInit in libVuforiaWrapper.a(DiagnosticsRecorder.o)

  "Vuforia::DiagnosticsRecorder::start()", referenced from:

      _diagnosticsRecorderStart in libVuforiaWrapper.a(DiagnosticsRecorder.o)

  "Vuforia::DiagnosticsRecorder::generateDiagnostics(char const*)", referenced from:

      _diagnosticsRecorderGenerateDiagnostics in libVuforiaWrapper.a(DiagnosticsRecorder.o)

  "Vuforia::DiagnosticsRecorder::deinit()", referenced from:

      _diagnosticsRecorderDeinit in libVuforiaWrapper.a(DiagnosticsRecorder.o)

ld: symbol(s) not found for architecture arm64

clang: error: linker command failed with exit code 1 (use -v to see invocation)

 

Has anyone encountered this?

iOS build failed

June 17, 2018 - 7:49pm #2

I have been struggling with the exact same thing for more than a week. I cannot find anything on the internet that helps. Lots of advice about Mach-O linking, but nothing that works. I even deleted and installed Unity again (2018.1.2f1 w/ Vuforia included).

 

Log in or register to post comments