Log in or register to post comments

iOS Camera does not track object

January 7, 2016 - 4:43pm #1

Hello!  I'm having a problem getting markers to track objects on my iPad.  In the Unity Editor on my MacBook I can get the object to track with my marker just fine.  When I deploy to iPad, my app boots up and the camera works, but the object doesn't track with my marker image.  I get this output in XCode.

[AVCaptureVideoDataOutput setVideoSettings:] - videoSettings dictionary contains one or more unsupported (ignored) keys: (
    Height,
    Width
)
cameraDeviceGetVideoMode
2016-01-07 18:13:54.755 vuforiatest[20513:17593591] VideoBackgroundConfig with screen size of zero received, skipping config step
cameraDeviceSelectVideoMode
cameraDeviceStartCamera
markerTrackerStart
objectTrackerStart
cameraDeviceGetVideoMode
Setting up 1 worker threads for Enlighten.
  Thread -> id: 9b13000 -> priority: 1 
cameraDeviceGetVideoMode
cameraDeviceGetVideoMode

 

Is there some setting I'm missing somewhere that would disallow object tracking specifically on iOS?  Thanks in advance for any help.

I'm using Unity 5.3.0f4, XCode 7.1.1, and an iPad 3 running iOS 8.1.3.

iOS Camera does not track object

January 19, 2016 - 1:22pm #6

Hey guys, sorry about the delay on my answer.  Thanks for all your responses!

I turns out the image that I was using was just fine for the mac but the iPad couldn't detect it.  I tried a couple other images and found one that worked.  I guess the iPad camera is just low quality or something.  I didn't expect there to be such a difference between the webcam on the macbook that I'm using and the camera on the iPad.

iOS Camera does not track object

January 19, 2016 - 10:18am #5

Hi,

had the same problem today with XCode 7.2 iOS 9.2 and found the solution: In XCode:

 

You need to go to your projects Build Phases -> Copy Bundle Resources, click the + sign, then click Add Other... and then select folder QCAR located in *ProjectRootPath*/Data/Raw/. Cheers!

 

Thanks to MapMan and benzsuankularb.

 

Torsten

iOS Camera does not track object

January 18, 2016 - 7:00pm #4

You might try including the stones and chips targets in your custom dataset as well. If the custom targets are tracking in Unity PlayMode, you may want to add some Debug.Log() statements in the TrackableEventHandler and watch Xcode output to see the logs.

iOS Camera does not track object

January 11, 2016 - 9:34am #3

I am.  Using the example project and the provided images works for me and the images track on my iPad.  It doesn't work with my own custom marker image though.  I have made sure to check the box under the Database Load Behaviour script to properly load the dataset.  I checked both the dataset and the activate boxes.  I confirmed that my custom marker image works on my MacBook in the Unity Editor but not on my iPad.

iOS Camera does not track object

January 8, 2016 - 2:33pm #2

Are you able to get the ImageTargets 5.0.10 sample app working okay?

https://developer.vuforia.com/downloads/samples

Log in or register to post comments