Log in or register to post comments

iPhone 6+ Memory crash (Unity3D)

February 6, 2015 - 11:39am #1

We have a test bed of iOS devices include iPhone 4s, 5s, 6, 6+, iPad 2, and iPad 4.  Vuforia is running reliably on all of these devices currently except iPhone 6+.

iPhone 6+ version of app runs for 10-15 seconds and then quits.

Device is up to date version of iOS, and Vuforia is the new 64 Bit build.  Unity is 4.6.2.  Xcode is 6.1.1

Tested restarting the phone to ensure no other apps are interfering.  I don't know of any system setting which could cause the issue.

This is part of the output that I'm seeing when running in XCode when it crashes:

 

WARNING -> applicationDidReceiveMemoryWarning()

cameraDeviceGetVideoMode

2015-02-06 12:10:43.003 tuneablesbookmo[2009:489753] Received memory warning.

WARNING -> applicationDidReceiveMemoryWarning()

cameraDeviceGetVideoMode

cameraDeviceGetVideoMode

2015-02-06 12:10:43.105 tuneablesbookmo[2009:489753] Received memory warning.

WARNING -> applicationDidReceiveMemoryWarning()

cameraDeviceGetVideoMode

 

These messages repeat and the app quits to desktop in around 10 seconds of starting regardless of the presense of any targets in the view.  Just start it and it dies.

 

This phone was showing the flashes of black screen, and if we do find a target it will react.  No additional information available about why the app crashes.

iPhone 6+ Memory crash (Unity3D)

March 27, 2015 - 11:25pm #10

Hi, 

here

https://developer.vuforia.com/forum/ios/unity-463-problems-ios

I think there is a solution to make Vuforia 3.0.9 working with unity 4.6.3,

but where to find info/samples for  Background Texture Access ?

.... unfortunately I can't update this project to Vuforia 4.0: it is started almost 1 year ago.

thahks

iPhone 6+ Memory crash (Unity3D)

March 26, 2015 - 10:48pm #9

Hi, 

the problem (iphone 6+ memory crash) does not exists when using version 4.6.3 of Unity , but in this case the black screen problem with a partial view of the camera appears, for that reading other posts it is suggested to use Unity 4.6.2 .... I don't know how to exit from this circle.

 

thanks

regards

m

iPhone 6+ Memory crash (Unity3D)

March 25, 2015 - 2:53pm #8

Hi , 

I have a very similar problem, but with Vuforia 3.09 :

tried with Unity 4.6.1 and 4.6.2 and Xcode 6.1.1.

With IPhone 5 , 6 , ipad , ipad air everything is ok, we tested also with 3 different 

iphone 6+ and only in one, after a while the App crash ,

the log has some memory warnings too. 

 

 

iPhone 6+ Memory crash (Unity3D)

March 24, 2015 - 2:43am #7

Hello,

I'm having the same problem, but funny enough, I have two iPhone 6+ devices. In one it works perfectly (16GB, model MGA92ZD/A) and in the other (64GB, model MGAJ2ZD/A) I get the memory warnings, blinking screen and crash after ~10 seconds, regardless of target presence. So, it is specific to some variant(s) of some model(s). You can find a video here: http://cloud.re-flekt.com/public.php?service=files&t=d18eed71464bb6c3920427f90b71a051

Crash log is attached.

 

I hope you can give us a solution soon, it is quite an urgent matter.

Diego

AttachmentSize
Plain text icon console_output.txt11.72 KB

iPhone 6+ Memory crash (Unity3D)

March 9, 2015 - 4:24pm #6

Can you gives us the exact steps to reproduce the issue? I tried on the iPhone 6+ that I had and built an Image Targets app from the ImageTargets-4-0-103.package and ran the app for more than an hour and didn't see any crash. I built the app using both Unity 4.6.2 and 4.6.3 and both worked fine. So exact steps to reproduce will be helpful. Thanks!

iPhone 6+ Memory crash (Unity3D)

March 9, 2015 - 1:57am #5

Does the issue persist if you tried building with Unity 4.6.3 (or latest 4.6.x)  ?

 

iPhone 6+ Memory crash (Unity3D)

March 7, 2015 - 10:23am #4

It seems like we are experiencing the exact same problem testing on an iPhone 6+ Vuforia 64bit build and Unity version 4.6.2f1. You can see the complete debug output here https://gist.github.com/tomaadland/6b2b1b3eb7be321f3e3e. This is running one of the core samples found here https://developer.vuforia.com/downloads/samples

The app starts and then crashes 10-15 seconds later. Does anyone have any idea what is going on here and how we can fix this ? Also to mention the build completes with 55 warnings most of them are Value Conversion Issues and some Deprecation warnings. 

 

 

iPhone 6+ Memory crash (Unity3D)

March 5, 2015 - 4:36am #3

What OS are all the devices running on? I'm noticing the same issue with devices running iOS 8. The minute the app starts there is a memory warning and then it quits. The exact same app is fine on an iOS 7 device. 

Running the app without Vuforia features works on iOS 8.

iPhone 6+ Memory crash (Unity3D)

February 6, 2015 - 2:28pm #2

Are you encountering the same w/ any of our samples? - please test w/ a similar sample if you haven't already.

Also did you follow the steps in the migration guide? - How-To-Migrate-Your-Existing-Apps

 

Log in or register to post comments