Log in or register to post comments

[Noob] How to use my own trackables? I can´t do it :(

July 4, 2012 - 3:00am #1

Hello all.

 

I make a multitarget trackable.

I download and I unzip it.

I obtaind mytrac.xml and mytrac.dat

I copy the files into the project, in the root path.

What steps I must follow?

I change all appareances of "FlakesBox" to "mytrac".  But, I obtained "Failed to load dataset".  Why?

 

All ideas are welcome.

 

Please, I need help 

 

Thanks!

[Noob] How to use my own trackables? I can´t do it :(

July 9, 2012 - 3:10am #6

Glad this helped you out.

Sometimes XCode does not do it for you ;)

 

N

[Noob] How to use my own trackables? I can´t do it :(

July 8, 2012 - 3:48pm #5

Woo! Thanks Nalins

I also had this problem, I'd drag/dropped the .xml and .dat files into the Assets folder in xcode and it seemed to be in my project so I couldn't understand the problem. It wasn't in the build phases tho, so I added it and now it works

Very new to this, I even had to google for the 'build phases tab' lol. Thanks tho, the first of many many problems I'm going to have answered lol

[Noob] How to use my own trackables? I can´t do it :(

July 6, 2012 - 7:13am #4

yes - sorry createMultiTarget is in QCARUtils

Just reviewing your email:

"I copy the files into the project, in the root path."

So just to check the files are in the app bundle?

Probably worth checking this by selecting the target and going to Build Phases tab and viewing under "Copy Bundle Resources"

Basically this message normally appears when it cannot find the files that are specified.

HTH

N

[Noob] How to use my own trackables? I can´t do it :(

July 5, 2012 - 1:50am #3

Hello.

 

 I don´t have

 

mit = currentDataSet->createMultiTarget("MyBox");

 

in EAGLView.mm I found it in QCARutils.mm

 

 ¿Is it right?  :S

 

 

And, I have the line:

[[QCARutils getInstance] addTargetName:@"My Box" atPath:@"MyBox.xml"];

 

in MultiTargetsAppDelegate.mm

 

 

Thanks.

[Noob] How to use my own trackables? I can´t do it :(

July 4, 2012 - 8:08am #2

Hi cesarruiznavarro

 

Can I just check you have also done the following:

in EAGLView.mm:    

                mit = currentDataSet->createMultiTarget("MyBox");


in MultiTargetsAppDelegate.mm

               [[QCARutils getInstance] addTargetName:@"My Box" atPath:@"MyBox.xml"];



N


Log in or register to post comments