Log in or register to post comments

periodic jitter / defocus on camera

January 17, 2019 - 1:23pm #1

Hi

Im running my AR on an iphone X

for the last year (vuforia 6, 7 and 8) Ive noticed a small jitter on the camera, it seems to happen more when I move

its like the camera tried to set the focus and this has a knockon effect on the camera position/zoom

if you watch the video attached you should see it happen for a split second, about every 2-3 seconds? seems to happen with a certain rhythm to it, like the camera is running through a process that repeats

 

cheers

tom

AttachmentSize
Package icon IMG_2269.TRIM 2.MOV_.zip6.91 MB

periodic jitter / defocus on camera

January 24, 2019 - 4:50am #5

wow , Im so surprised because overall I found ARkit super stable and nice compared to any other phone based AR I tried (still havent tried ARcore though)

I'll check back in on this in 3 months and see how they are getting on!

thanks

Tom

periodic jitter / defocus on camera

January 22, 2019 - 1:29pm #4

Hello,

Your findings agree with ours that this is an ARKit issue. We (and many others) have reported this to Apple on multiple occasions.

Thanks,

Vuforia Engine Support

periodic jitter / defocus on camera

January 22, 2019 - 4:15am #3

Hi medabit

so does ARkit do this by itself if implemented natively? (i..e no unity / vuforia etc.)

my experiments seem to confirm it does!

I just tried Ikea's place app on ios, and also apple's measure app, and Im shocked, its happening there too!



this is quite a bad glitch /bug they have, have you guys reported it to them?

best

Tom

periodic jitter / defocus on camera

January 18, 2019 - 9:13am #2

Hello,

Vuforia relies upon the platform OS for continuous autofocus implementation. We've noticed this type of a "pump" effect on iOS device since we've integrated with ARKit with Engine SDK 7.0.

Thanks,

Vuforia Engine Support

Log in or register to post comments