Log in or register to post comments

Problem running on iOS 11.2.5

February 15, 2018 - 3:45am #1

Hello everyone,

We are trying to upload our Vuforia AR app to the iOS Store. But we have a problem with iPad's running iiOS 11.2.5 on Wi-Fi connected to an IPv6 network. On all other (older) versions of iOS it does work. But for iOS 11.2.5 the AR scene won't load... 

We are using Unity 2017.3.1f1 which has Vuforia integrated and Xcode 9.2

Does anyone have an idea on how to fix this?

Thanks in advance!

Problem running on iOS 11.2.5

March 14, 2018 - 10:55am #6

Hello all,

We're investigating this issue over on this thread: https://developer.vuforia.com/forum/ios/ios-apps-failing-app-review-vuforia-7047-and-unity-201731f1

Please post any relevant logs you have to that thread as it will help our investigation.

Thanks,

Vuforia Support

Problem running on iOS 11.2.5

March 13, 2018 - 3:30pm #5

Hi StudioBleep, sounds like you might be running into the same issue that a lot of us are as described here:

 

https://developer.vuforia.com/forum/ios/ios-apps-failing-app-review-vuforia-7047-and-unity-201731f1 ?

 

Perhaps you could post in that thread and hopefully if enough people comment it might get fixed.

Problem running on iOS 11.2.5

March 9, 2018 - 5:23am #4

We managed to solve the bug. We started with a clean project, reinstalled the databases (this already solved a few issues) and we changed the way we switched between the AR scenes. Now all the AR scenes work. 

But Apple now says the app crashed "Your app crashed on iPad or iPhone running iOS 11.2.5 connected to an IPv6 network during our review." We tried everything, but can't reproduce this crash. Do they wait until an app crashes or do they sometimes quit because the loading time takes too long? (also couldn't reproduce that, but we are desperate by this point :P) Everything works perfectly fine on our testing devices (also used the iPad iOS 11.2.5 with IPv6 network).

Does anyone have experience with this?

Problem running on iOS 11.2.5

February 24, 2018 - 5:02am #3

StudioBleep wrote:

Hello everyone,

We are trying to upload our Vuforia AR app to the iOS Store. But we have a problem with iPad's running iOS 11.2.5 on Wi-Fi connected to an IPv6 network. On all other (older) versions of iOS it does work. But for iOS 11.2.5 the AR scene won't load... 

We are using Unity 2017.3.1f1 which has Vuforia integrated and Xcode 9.2

Does anyone have an idea on how to fix this?

Thanks in advance!

Yes! I'm encountering this very same error while testing my AR app on iPhone 7 and iPhone 7+ running iOS 11.3. Couldn't get any way around to make it work out need to get it resolved asap.

Problem running on iOS 11.2.5

February 23, 2018 - 2:31am #2

I have tried a lot of different things. I now think it has something to do with switching between multiple AR scenes. We have a main AR scene which loads image targets, some image targets switch to a new scene where another AR camera is present. We want to be able to still see the video background in the new scene. 

So we have a main menu scene which loads to the main AR scene. The main AR scene has image targets which then lead to another Ar scene. The problem is that the main AR scene (and with that all other AR scenes) won't load after the menu.

For Android we do not have any problems...

Is there someone who has experience with switching between multiple AR scenes in 1 app?

Log in or register to post comments