Log in or register to post comments

rarely drawVideoBackground return false when resume camera.

January 27, 2014 - 12:20am #1
OS : iOS5.0 and iOS5.1.1 
SDK: Ver.2.6.8
 
I use Cloud Reco.
When it is pressed the home button, pause the camera. 
There rarely is that when you then return to the foreground, the video camera is not recovered even to resume the camera, OnUpdate function is also not run. 
At this time, drawVideoBackground function that is called in render_frame function will return "false".
But, scanbar is running.
 
What is "false" meaning?
What can the cause which will be in this state consider? 
 
Pause camera in applicationWillResignActive,
and resume camera in applicationDidBecomeActive.
 
When I retry with Press home button and resume App, the app works fine.

rarely drawVideoBackground return false when resume camera.

January 28, 2014 - 6:04am #5

Thanks for this.

However this is an iOS5 specific issue, and given that these devices represent less than 4% of devices according to Apple's latest figures

http://appleinsider.com/articles/13/12/05/apple-pegs-ios-7-distribution-at-74-ios-6-at-22

..and the fact that it is a specific app, the chances are that it will not affect many users.

 

Therefore it is probably unlikely that this issue will be resolved.

Hope you can understand.

thanks

rarely drawVideoBackground return false when resume camera.

January 28, 2014 - 2:53am #4
SampleApp : Ver.2.8.9
Vuforia   : SDK Ver.2.8.7
Device    : iPhone4
OS        : iOS5.0

You can reproduce by following these steps:

1. Open the VuforiaSamples XCode project, then Build and Run.
2. Choose the "Cloud Reco" example from the menu.
3. Press the "Start" button.
4. Press the Home button at the bottom of device.
5. Launch "Vuforia" app on the home screen
6. Go back to #4 and repeat.

 

rarely drawVideoBackground return false when resume camera.

January 27, 2014 - 4:52pm #3

It does not reproduce in iOS6 & iOS7.

I'll try to reproduce with the latest SDK.

If the problem has been reproduced, I will write here.

rarely drawVideoBackground return false when resume camera.

January 27, 2014 - 12:34am #2

What happens when you try iOS6 & iOS 7?

Can you reproduce this with the latest SDK?  as previous versions are no longer supported.

 

There rarely is that when you then return to the foreground, the video camera is not recovered

What are the exact steps are to reproduce this?

 

N

Log in or register to post comments