Log in or register to post comments

Sample Core 7.5.26 fails to run

October 29, 2018 - 9:43pm #1

I'm just getting started with Vuforia and wanted to get the sample core app up and running. The Vuforia framework that is added to the project has a relative folder of ../../build which doesn't exist. I've remapped that to the framework included with the project. There is a warning indicating that the Frameworks path includes ../../build which doesn't exist. On the assumption it's supposed to point to the framework I've edited that build setting to point to the folder the framework is actually located in.

There are no other build errors or warnings of note. I then try to run the app using XCode 10.0 on my iPhone8 running iOS 12.0.1. The app installs then the splash screen displays and then the debugger breaks with Thread 1: signal SIGABORT and the following in the lldb output console:

dyld: Library not loaded: @rpath/Vuforia.framework/Vuforia

Referenced from: /var/containers/Bundle/Application/{Guid}/Vuforia.app/Vuforia

Reason: image not found

 

I would have thought the samples SHOULD be able to be run without too many hoops jumped through. There are mentions of similar issues on StackOverflow regarding the dyld library not loaded but none of the fixes so far have resolved the issue for me.

Is there something I need to be doing to get this working??

 

Sample Core 7.5.26 fails to run

October 30, 2018 - 8:13pm #4

I've worked out what was wrong for anyone else who runs into this issue. When I was adding the framework to my projects I was dragging and dropping them (it's been a while since I had to do this!). It was being added as a 'linked' framework. Turns out it needs to be added as an Embedded framework. So go to the target settings->General tab. Scroll down until you see Embedded Binaries (above Linked Frameworks and Libraries). Click the + and add the Vuforia framework. Voila!

Sample Core 7.5.26 fails to run

October 30, 2018 - 1:32am #3

Aaand then I find the 'special instructions' that explain how you need to put the sample code in the SDK samples folder to get it to work. And now it works. But I'm pretty concerned about getting it working for my own app now given the problems I've run into with the sample...

Sample Core 7.5.26 fails to run

October 30, 2018 - 12:09am #2

I've also tried the Swift sample found here. I dropped the current framework in place of the 7.0.50 version. Had to fix some build errors due to changes in the framework. Compiled fine after that but when I ran it I got the exact same error.

Is it possible there is something wrong with the iOS framework (7.5.26)??

Log in or register to post comments