Log in or register to post comments

Support iOS 8 with Vuforia 6.5 built in Unity 2017.2

November 15, 2017 - 1:52am #1

Hello. I'm trying to deploy Unity App with Vuforia on iPad with iOS 8. I'm using Unity 2017.2 and XCode 9.1. An XCode throws warnings and errors while Linking: ld: warning: object file (/Users/Initlab/savinov/New Unity Project/build/Libraries/libVuforiaWrapper.a(Tracker.o)) was built for newer iOS version (9.2) than being linked (8.0) ld: warning: object file (/Users/Initlab/savinov/New Unity Project/build/Libraries/libVuforiaWrapper.a(Renderer.o)) was built for newer iOS version (9.2) than being linked (8.0) ld: warning: object file (/Users/Initlab/savinov/New Unity Project/build/Libraries/libVuforiaWrapper.a(CameraDevice.o)) was built for newer iOS version (9.2) than being linked (8.0) ld: warning: object file (/Users/Initlab/savinov/New Unity Project/build/Libraries/libVuforiaWrapper.a(QCAR.o)) was built for newer iOS version (9.2) than being linked (8.0) ld: warning: object file (/Users/Initlab/savinov/New Unity Project/build/Libraries/libVuforiaWrapper.a(ViewerParameters.o)) was built for newer iOS version (9.2) than being linked (8.0) ld: warning: object file (/Users/Initlab/savinov/New Unity Project/build/Libraries/libVuforiaWrapper.a(CylinderTarget.o)) was built for newer iOS version (9.2) than being linked (8.0) ld: warning: object file (/Users/Initlab/savinov/New Unity Project/build/Libraries/libVuforiaWrapper.a(DataSet.o)) was built for newer iOS version (9.2) than being linked (8.0) ld: warning: object file (/Users/Initlab/savinov/New Unity Project/build/Libraries/libVuforiaWrapper.a(Eyewear.o)) was built for newer iOS version (9.2) than being linked (8.0) ld: warning: object file (/Users/Initlab/savinov/New Unity Project/build/Libraries/libVuforiaWrapper.a(Device.o)) was built for newer iOS version (9.2) than being linked (8.0) ld: warning: object file (/Users/Initlab/savinov/New Unity Project/build/Libraries/libVuforiaWrapper.a(EyewearCalibrationProfileManager.o)) was built for newer iOS version (9.2) than being linked (8.0) ld: warning: object file (/Users/Initlab/savinov/New Unity Project/build/Libraries/libVuforiaWrapper.a(EyewearUserCalibrator.o)) was built for newer iOS version (9.2) than being linked (8.0) ld: warning: object file (/Users/Initlab/savinov/New Unity Project/build/Libraries/libVuforiaWrapper.a(FrameCounter.o)) was built for newer iOS version (9.2) than being linked (8.0) ld: warning: object file (/Users/Initlab/savinov/New Unity Project/build/Libraries/libVuforiaWrapper.a(QCARWrapper.o)) was built for newer iOS version (9.2) than being linked (8.0) ld: warning: object file (/Users/Initlab/savinov/New Unity Project/build/Libraries/libVuforiaWrapper.a(ImageTargetBuilder.o)) was built for newer iOS version (9.2) than being linked (8.0) ld: warning: object file (/Users/Initlab/savinov/New Unity Project/build/Libraries/libVuforiaWrapper.a(ImageTarget.o)) was built for newer iOS version (9.2) than being linked (8.0) ld: warning: object file (/Users/Initlab/savinov/New Unity Project/build/Libraries/libVuforiaWrapper.a(VuforiaUnityPlayer.o)) was built for newer iOS version (9.2) than being linked (8.0) ld: warning: object file (/Users/Initlab/savinov/New Unity Project/build/Libraries/libVuforiaWrapper.a(MultiTarget.o)) was built for newer iOS version (9.2) than being linked (8.0) ld: warning: object file (/Users/Initlab/savinov/New Unity Project/build/Libraries/libVuforiaWrapper.a(NativeUnityInterface.o)) was built for newer iOS version (9.2) than being linked (8.0) ld: warning: object file (/Users/Initlab/savinov/New Unity Project/build/Libraries/libVuforiaWrapper.a(ObjectTarget.o)) was built for newer iOS version (9.2) than being linked (8.0) ld: warning: object file (/Users/Initlab/savinov/New Unity Project/build/Libraries/libVuforiaWrapper.a(ObjectTracker.o)) was built for newer iOS version (9.2) than being linked (8.0) ld: warning: object file (/Users/Initlab/savinov/New Unity Project/build/Libraries/libVuforiaWrapper.a(SmartTerrainTracker.o)) was built for newer iOS version (9.2) than being linked (8.0) ld: warning: object file (/Users/Initlab/savinov/New Unity Project/build/Libraries/libVuforiaWrapper.a(RenderingPrimitives.o)) was built for newer iOS version (9.2) than being linked (8.0) ld: warning: object file (/Users/Initlab/savinov/New Unity Project/build/Libraries/libVuforiaWrapper.a(DeviceTracker.o)) was built for newer iOS version (9.2) than being linked (8.0) ld: warning: object file (/Users/Initlab/savinov/New Unity Project/build/Libraries/libVuforiaWrapper.a(TargetFinder.o)) was built for newer iOS version (9.2) than being linked (8.0) ld: warning: object file (/Users/Initlab/savinov/New Unity Project/build/Libraries/libVuforiaWrapper.a(TextTracker.o)) was built for newer iOS version (9.2) than being linked (8.0) ld: warning: object file (/Users/Initlab/savinov/New Unity Project/build/Libraries/libVuforiaWrapper.a(TrackerManager.o)) was built for newer iOS version (9.2) than being linked (8.0) ld: warning: object file (/Users/Initlab/savinov/New Unity Project/build/Libraries/libVuforiaWrapper.a(ViewerParametersList.o)) was built for newer iOS version (9.2) than being linked (8.0) ld: warning: object file (/Users/Initlab/savinov/New Unity Project/build/Libraries/libVuforiaWrapper.a(VirtualButton.o)) was built for newer iOS version (9.2) than being linked (8.0) ld: warning: object file (/Users/Initlab/savinov/New Unity Project/build/Libraries/libVuforiaWrapper.a(VuMarkTemplate.o)) was built for newer iOS version (9.2) than being linked (8.0) ld: warning: object file (/Users/Initlab/savinov/New Unity Project/build/Libraries/libVuforiaWrapper.a(WordList.o)) was built for newer iOS version (9.2) than being linked (8.0) ld: warning: object file (/Users/Initlab/savinov/New Unity Project/build/Libraries/libVuforiaWrapper.a(Platform.o)) was built for newer iOS version (9.2) than being linked (8.0) ld: warning: object file (/Users/Initlab/savinov/New Unity Project/build/Libraries/libVuforiaWrapper.a(StateHolder.o)) was built for newer iOS version (9.2) than being linked (8.0) ld: warning: object file (/Users/Initlab/savinov/New Unity Project/build/Libraries/libVuforiaWrapper.a(TypeMapping.o)) was built for newer iOS version (9.2) than being linked (8.0) ld: warning: object file (/Users/Initlab/savinov/New Unity Project/build/Libraries/libVuforiaWrapper.a(PlatformiOS.o)) was built for newer iOS version (9.2) than being linked (8.0) Undefined symbols for architecture arm64: "__SetStatusBarAnimation", referenced from: _StatusBarManager__SetStatusBarAnimation_m2531039878 in Bulk_Assembly-CSharp_1.o _StatusBarManager_BarAnim_m351821396 in Bulk_Assembly-CSharp_1.o (maybe you meant: _StatusBarManager__SetStatusBarAnimation_m2531039878) "__SetStatusBarStyle", referenced from: _StatusBarManager__SetStatusBarStyle_m647231709 in Bulk_Assembly-CSharp_1.o _StatusBarManager_BarStyle_m1272574606 in Bulk_Assembly-CSharp_1.o (maybe you meant: _StatusBarManager__SetStatusBarStyle_m647231709) "__ShowStatusBar", referenced from: _StatusBarManager__ShowStatusBar_m2397003652 in Bulk_Assembly-CSharp_1.o _StatusBarManager_Show_m2323108115 in Bulk_Assembly-CSharp_1.o (maybe you meant: _StatusBarManager__ShowStatusBar_m2397003652) ld: symbol(s) not found for architecture arm64 clang: error: linker command failed with exit code 1 (use -v to see invocation)

Log in or register to post comments