Log in or register to post comments

UIView does not respond to selector renderFrameVuforia

January 19, 2019 - 7:21am #1

Hi Guys, I'm creating a app using Vuforia in unity.

I have a main.scene that is just a main menu (without vuforia).

Then I have some AR Scenes that are called from my main menu.

It works fine in Unity and Andoid, but when I try to build in xcode, it build correctly but when starts the app, I'm not able to touch any button. The screen appears to blink sometimes but nothing happens.

My Config:

Unity 2018.3.1f1

Vuforia 8.0.10

Xcode 10.1

Macbook Pro mid 2010 (without metal support)

MacOS High Sierra

Xcode show me the following log:

2019-01-19 13:01:06.931415-0200 gremioapp[2479:1062895] INFO/AR(2479) 2019-01-20 13:01:06: Vuforia selected rendering API OpenGL ES 2.x

2019-01-19 13:01:06.931440-0200 gremioapp[2479:1062895] INFO/AR(2479) 2019-01-20 13:01:06: Vuforia SDK version 8.0.10

2019-01-19 13:01:07.020462-0200 gremioapp[2479:1062895] INFO/AR(2479) 2019-01-20 13:01:07: Matched precache profile for Apple, iPhone9,4, iOS 12, 800.1

2019-01-19 13:01:08.437685-0200 gremioapp[2479:1062895] INFO/AR(2479) 2019-01-20 13:01:08: Vuforia Fusion: Detected and enabled use of ARKit

2019-01-19 13:01:08.447327-0200 gremioapp[2479:1062895] Rendering mode set to: OpenGL ES 2.0

2019-01-19 13:01:08.489948-0200 gremioapp[2479:1062895] Rendering mode set to: OpenGL ES 2.0

2019-01-19 13:01:08.492878-0200 gremioapp[2479:1062895] DEBUG/AR(2479) UIView has CAEAGLLayer layer class

2019-01-19 13:01:08.493169-0200 gremioapp[2479:1062895] DEBUG/AR(2479) UIView does not respond to selector renderFrameVuforia

2019-01-19 13:01:08.493325-0200 gremioapp[2479:1062895] DEBUG/AR(2479) UIView has CAEAGLLayer layer class

2019-01-19 13:01:08.493456-0200 gremioapp[2479:1062895] DEBUG/AR(2479) UIView does not respond to selector renderFrameVuforia

2019-01-19 13:01:08.493586-0200 gremioapp[2479:1062895] DEBUG/AR(2479) Could not find a UIView with CAEAGLLayer or CAMetalLayer layer class that responds to selector renderFrameVuforia

Setting up 1 worker threads for Enlighten.

UIView does not respond to selector renderFrameVuforia

June 6, 2019 - 2:12pm #5

Hello @reddo,

Is this being observed when you run Vuforia Engine's native iOS samples? https://developer.vuforia.com/downloads/samples

Thanks,

Vuforia Engine Support

UIView does not respond to selector renderFrameVuforia

June 4, 2019 - 7:40am #4

I'm getting similar errors, namely

UIView does not respond to selector renderFrameVuforia.

Could not find a UIView with CAEAGLLayer or CAMetalLayer layer class that responds to selector renderFrameVuforia 

 

The app builds but can't detect any Vumarks . Works ok in the Unity editor. Tried both with Metal and OenGL ES  2.0 and 3.0. 

Is there an update on this? Thanks

Unity 2018.3.11

Vuforia 8.1.10

XCode 10.2.1

iPadMini with iOS 12.3.1

 

UIView does not respond to selector renderFrameVuforia

April 2, 2019 - 2:05am #3

I have the same issue. Did you find any solution to this?

UIView does not respond to selector renderFrameVuforia

April 2, 2019 - 1:38am #2

I have the same issue. Did you find any solution to this?

Log in or register to post comments